eZ Community » Security Advisories » EZSA-2018-008: REST API returns list...

EZSA-2018-008: REST API returns list of all SiteAccesses

Publication date : 21/11/2018
Severity : Medium
Affected versions : ezsystems/ezpublish-kernel v7.3.2, v7.2.4, v6.13.5, v6.7.9
Resolving versions : ezsystems/ezpublish-kernel v7.3.2.1, v7.2.4.1, v6.13.5.1, v6.7.9.1

This security advisory fixes a vulnerability in eZ Platform, and we recommend that you install it as soon as possible. The issue is that the REST API may be made to disclose the names of all available site accesses. The severity of this depends on your installation, please consider your response accordingly.

To install, use Composer to update "ezsystems/ezpublish-kernel" to one of the "Resolving versions" mentioned above, or apply this patch manually:
https://github.com/ezsystems/ezpublish-kernel/commit/1551723ec134878a4cb598bfc5d900ba6164117a

Have you found a security bug in eZ Publish or eZ Platform? See how to report it responsibly here: https://doc.ez.no/Security

36 542 Users on board!

Community Project menu

Proudly Developed with from