eZ Community » Forums » Developer » PLEASE HELPPP : changeFilePermissions
expandshrink

PLEASE HELPPP : changeFilePermissions

PLEASE HELPPP : changeFilePermissions

Wednesday 09 September 2015 4:05:05 pm - 1 reply

Hello everyone, 

I dont stop to get this line of code in my error.log

 

eZImageHandler::changeFilePermissions:

Chmod 0666 var/ezwebin_site/storage/images/media/images... ...image.jpg failed

I dont undestand i have rwxrwxrwx (0777) in all my files in storage dir.

 

   
 
        ## Versions prior to 5.4:
 
        #RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* /index_cluster.php [L]
 
        #RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* /index_cluster.php [L]
 
 
 
        RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]
 
        RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
 
        RewriteRule ^/design/[^/]+/(stylesheets|images|javascript|fonts)/.* - [L]
 
        RewriteRule ^/share/icons/.* - [L]
 
        RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|fonts|lib|javascripts?)/.* - [L]
 
        RewriteRule ^/packages/styles/.+/(stylesheets|images|fonts|javascript)/[^/]+/.* - [L]
 
        RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
 
        RewriteRule ^/var/storage/packages/.* - [L]
 
        # Uncomment the following lines when using popup style debug in legacy
 
        #RewriteRule ^/var/([^/]+/)?cache/debug\.html.* - [L]
 
        # Following rule is needed to correctly display assets from eZ Publish5 / Symfony bundles
 
        RewriteRule ^/bundles/ - [L]
 
        # Additional Assetic rules for environments different from dev,
 
        # remember to run php ezpublish/console assetic:dump --env=prod
 
        RewriteCond %{ENV:ENVIRONMENT} !("dev")
 
        RewriteRule ^/(css|js)/.*\.(css|js) - [L]
 
        # Conditions for enabling webdav and soap interfaces from legacy
 
        ## Symlink files into your web folder and correct domain names to be valid server aliases
 
        RewriteCond %{HTTP_HOST} ^webdav\..*
 
        RewriteRule ^(.*) /webdav.php [L]
 
        RewriteCond %{HTTP_HOST} ^soap\..*
 
        RewriteRule ^(.*) /soap.php [L]

 

I have to add that i dont have any problem with viewing the photos.

Some config wich can be helpfull:

PHPVersion: 5.6.9-0+deb8u1 

Divers:Le "safe mode" est inactif.

La restriction de "Basedir" est inactive.

L'enregistrement des variables globales est inactif.

Le chargement de fichiers est actif.

La taille maximale des données (texte ou fichier) chargeable est 80M.

La limite de mémoire pour les scripts est 256M.

Le temps maximum d'exécution est de 300 secondes.

Serveur web (logiciel)

Nom:ApacheVersion:Apache/2.4.10 (Debian)
Modules:core, mod_so, mod_watchdog, http_core, mod_log_config, mod_logio, mod_version, mod_unixd, mod_access_compat, mod_alias, mod_auth_basic, mod_authn_core, mod_authn_file, mod_authz_core, mod_authz_host, mod_authz_user, mod_autoindex, mod_deflate, mod_dir, mod_env, mod_filter, mod_mime, prefork, mod_negotiation, mod_php5, mod_rewrite, mod_setenvif, mod_status

Modified on Friday 11 September 2015 5:30:19 pm by Nana At

Tuesday 22 September 2015 11:47:40 am

Hi,

You get this error because of ImagePermissions setting in FileSettings group in your image.ini.

Everything should works correctly with those errors, but if you want to get rid of mess in log file you can change ImagePermissions setting to 0777 or, what's the better solution, set your image directory to 0666 and change its owner to your web server user.

Cheers,
Michał

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from