eZ Community » Forums » Extensions » eZ Find » updatesearchindexsolr.php hangs
expandshrink

updatesearchindexsolr.php hangs

updatesearchindexsolr.php hangs

Thursday 18 November 2010 5:24:01 am - 2 replies

I had a situation where updatesearchindexsolr.php was hanging at the same place all the time. I tried different users, manually deleting stuff, pointless repetitions, etc.

Watching the output from solr (bash solr.sh), it always looked like this:

[...]

INFO: {add=[2e9e13c1994c4ed227d91a76506e757b]} 0 2
Nov 17, 2010 9:54:27 PM org.apache.solr.core.SolrCore execute
INFO: [] webapp=/solr path=/update params={} status=0 QTime=2
Nov 17, 2010 9:54:27 PM org.apache.solr.update.processor.LogUpdateProcessor finish
INFO: {add=[e6082f9d6f6caebc706870925caeb684]} 0 3

and then nothing. I could do searches, but killing and restarting the updatesearchindex did nothing.

At first I thought the big identifiers (add=[ ... ]) were remote ids, but that doesn't seem to be the case since I get null with eZContentObject::fetchByRemoteID().

Then I tried searching in the solr admin interface (http://foo.ca:8983/solr/admin/) for the big identifier - That generated hits.

So then I edited and republished the suspect object (and a couple parents, for good measure) and now updatesearchindex is running find. Er, fine.

Modified on Thursday 18 November 2010 5:24:55 am by Doug Plant

Thursday 18 November 2010 8:49:09 pm

hi there. can you put the exact command you're usign? i had some problems because not adding -s option...

Thursday 18 November 2010 9:06:43 pm

Sure,

php extension/ezfind/bin/php/updatesearchindexsolr.php -s <admin siteaccess> --php-exec=/usr/bin/php

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from