eZ Community » Forums » eZ Publish 5 Platform » eZ Publish 2014.11 and php 7.0
expandshrink

eZ Publish 2014.11 and php 7.0

eZ Publish 2014.11 and php 7.0

Friday 12 January 2018 4:00:44 pm - 2 replies

Hello again.

Following my disappointment on eZ 2014.11 and php7.1. I downgrade to php7.0

http://share.ez.no/forums/ez-publ...sh-2014.11-and-php-7.1/(offset)/last

 

The site in front and BO works happy.gif Emoticon

 But the cache:clear makes a mistake:

  php ezpublish/console cache:clear --env=dev

[Symfony \ Component \ Debug \ Exception \ ContextErrorException]
Warning: Parameter 1 to

eZ\Bundle\EzPublishLegacyBundle\DependencyInjection\EzPublishLegacyExtension::eZ\Bundle\EzPublishLegacyBundle\DependencyInjection\{closure}()

expected to be a reference, value given

 php -v

PHP 7.0.27 (cli) (built: Jan 2 2018 12:38:03) (NTS)
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.27, Copyright (c) 1999-2017, by Zend Technologies
    with Xdebug v2.5.5, Copyright (c) 2002-2017, by Derick Rethans

Modified on Friday 12 January 2018 4:11:26 pm by Rémy PHP

Friday 12 January 2018 4:09:40 pm

 

 Exception trace:
 () at /var/www/2014.11/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/DependencyInjection/Configuration/SiteAccessAware/ConfigurationProcessor.php:111
 Symfony\Component\Debug\ErrorHandler->handleError() at n/a:n/a
 call_user_func_array() at /var/www/2014.11/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/DependencyInjection/Configuration/SiteAccessAware/ConfigurationProcessor.php:111
 eZ\Bundle\EzPublishCoreBundle\DependencyInjection\Configuration\SiteAccessAware\ConfigurationProcessor->mapConfig() at /var/www/2014.11/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishLegacyBundle/DependencyInjection/EzPublishLegacyExtension.php:71
 eZ\Bundle\EzPublishLegacyBundle\DependencyInjection\EzPublishLegacyExtension->load() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/MergeExtensionConfigurationPass.php:59
 Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/MergeExtensionConfigurationPass.php:39
 Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/Compiler.php:102
 Symfony\Component\DependencyInjection\Compiler\Compiler->compile() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ContainerBuilder.php:583
 Symfony\Component\DependencyInjection\ContainerBuilder->compile() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:512
 Symfony\Component\HttpKernel\Kernel->initializeContainer() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php:131
 Symfony\Component\HttpKernel\Kernel->boot() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:61
 Symfony\Bundle\FrameworkBundle\Console\Application->doRun() at /var/www/2014.11/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/Console/Application.php:41
 eZ\Bundle\EzPublishCoreBundle\Console\Application->doRun() at /var/www/2014.11/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php:117
 Symfony\Component\Console\Application->run() at /var/www/2014.11/ezpublish/console:27

Friday 12 January 2018 4:25:29 pm

I missed this in your previous thread:

"Subsidiary question: Is 2014.11 the equivalent of 5.4?"

No. eZ Publish/Platform 5.4 has been updated to support PHP 7.0, after it's initial release. The community version got PHP 7 support in v2017.10, not before.

2014.11 composer.json says "php": ">=5.3.3"
https://github.com/ezsystems/ezpublish-legacy/blob/v2014.11.2/composer.json#L15

2017.10 says "php": "~5.5|~7.0"
 https://github.com/ezsystems/ezpublish-legacy/blob/v2017.10.0/composer.json#L20

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from