eZ Community » Forums » eZ Publish 5 Platform » eZ Publish 2014.11 and php 7.1
expandshrink

eZ Publish 2014.11 and php 7.1

eZ Publish 2014.11 and php 7.1

Friday 12 January 2018 2:31:45 pm - 5 replies

Hello everyone.

I need to prepare a site to run it on CentOS7 with php7.1

But after updating the php version from 5.4.16 to 7.1 I have this error:

 Fatal error: Can not use 'null' as class name as it is reserved in  /var/www/lurton/2014.11/vendor/ezsystems/comments-bundle/EzSystems/CommentsBundle/Comments/Provider/Null.php  on line 16

My composer.json states:

 "ezsystems/comments-bundle": ">=2014.11",

So .. Is eZ 2014.11 compatible with php7?

Or did I miss something?

Subsidiary question: Is 2014.11 the equivalent of 5.4?

Thanks for your help happy.gif Emoticon

Modified on Friday 12 January 2018 4:54:25 pm by Rémy PHP

Friday 12 January 2018 2:36:44 pm

I tried to remove the depenity at ezsystems / comments-bundle because I'm not sure it's useful ..

 php -d memory_limit = -1 composer.phar remove ezsystems/comments-bundle

But suddenly I end up with the same error but for ezsystems / ezpublish-kernel

Which seems to me indispensable ...

 Fatal error: Can not use 'null' as class name as it is reserved in  /var/www/lurton/2014.11/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Persistence/Legacy/Content/FieldValue/Converter/Null  .php on line 21

Modified on Friday 12 January 2018 2:38:32 pm by Rémy PHP

Friday 12 January 2018 2:54:46 pm

AFAIK, eZ Publish 5.4 works with PHP 7.0 but not 7.1.

See also https://doc.ez.no/display/EZP/Considerations+when+running+5.4+on+PHP7

Friday 12 January 2018 3:47:17 pm

Thanks Gunnstein Lye.

I downgraded to 7.0 and it seems like my problems are fixed. (At the moment :$ )

Friday 12 January 2018 4:54:06 pm

Ha zut.
My illusory happiness was short-lived ..
I had not restarted httpd. So he was still running with php 5.4.
I restarted httpd and there it takes php7.0 and suddenly:
Fatal error: Cannot use 'Null' as class name as it is reserved

Friday 12 January 2018 5:04:26 pm

Hi Rémy,

2014.11 is definitely not compatible with PHP 7.0 and later.

As for 5.4, earlier patch versions definitelly weren't compatible with PHP 7.0, but latest 5.4.11 is.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from