eZ Community » Forums » eZ Publish 5 Platform » Is upgrading via Composer reliable ?
expandshrink

Is upgrading via Composer reliable ?

Is upgrading via Composer reliable ?

Tuesday 16 December 2014 11:08:25 am - 3 replies

Hello,

I tried to upgrade an eZ Publish installation with Composer, as explained in the documentation:

composer update --no-dev --prefer-dist

I had to edit my composer.json because of an issue with the scripts used by Composer.

My installation is now updated but i have an error when I try to access the '/blog' url:

 Runtime Notice: Declaration of eZ\Bundle\EzPublishCoreBundle\Controller::isGranted() should be compatible with Symfony\Bundle\FrameworkBundle\Controller\Controller::isGranted($attributes, $object = NULL)

It looks like there is a compatibility problem with the latest version of symfony suspicious.gif Emoticon

I'm wondering if upgrading using composer is a good idea, or if it is only useful for desting/developement purpose.

Maybe staying with the versions found in the distribution archive is safer ?

Modified on Tuesday 16 December 2014 11:18:27 am by Mickaël Raybaud-Roig

Wednesday 17 December 2014 12:53:10 am

Hello,

This problem was already resolved in this post. You have to change in your composer.json the Symfony version:

"symfony/symfony": "~2.5" => "symfony/symfony": "~2.5.0"

Modified on Wednesday 17 December 2014 12:53:50 am by Soufian DAOUDI

Thursday 18 December 2014 8:49:02 am

Quote from Soufian DAOUDI :

Hello,

This problem was already resolved in this post. You have to change in your composer.json the Symfony version:

"symfony/symfony": "~2.5" => "symfony/symfony": "~2.5.0"

Hello,

I made the modification and this solved the problem. Thanks happy.gif Emoticon

Thursday 21 May 2015 3:27:16 pm

Thanks it's works for me too.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from