Friday 24 April 2015 2:43:20 am - 8 replies
I like almost all of the new stack terms. For example:
node = location
attribute = field
datatype = field type
class = content type
What I really don't like is the fact that a content object is now just called "content". This leads to you calling it "a content". A content what? It is awkward to say and is confusing. "Content" on its own makes sense: "I create content". "A piece of content" works: "I created a piece of content". But you can't just say: "I created a content".
For lack of a better alternative "content object" would still work. Maybe "content item".
Friday 24 April 2015 8:41:37 am
Interesting, thank you for raising that up.
We've been using the term for so long... it's hard to say, from my perspective at least, that it doesn't work. But I see what you mean. I very often want to say "a Content object"... ironic is it not ? In french, I don't think that "a Content" worked before. "Some content" did. But I think that it started making sense, at least for CMS editors, for instance when describing scenarii.
- When I create a Content
- When I edit a Content of type Article
But with the sentence above, it would actually be more meaningful to say "When I create an Article", but since "Article", or any Content Type, only makes sense in the context of a particular project's domain...
The other ironic thing is that looking at it, "Content" is kind of a meta-value object. It's actually almost more of a service than of an object, since it has two properties (+ a private one), and 4 methods (even more in the implementation. What we actually care about in a Content is either the Content Metadata (Content Info), or the Fields (from a version).
Monday 27 April 2015 9:18:08 am
I agree completely with Peter. Sometimes it is difficult to give a good name for a class that works with "content".
E.g. ContentTypeDecorator is ok and clear, but ContentDecorator is not ok. I renamed it to ContentItemDecorator but not satisfied with it because this class name is not consistent with eZ Publish naming (ContentService, ContentCreateStruct etc).
Another problem is writing documentation. What about "You can see 5 contents in search results"? Of course "5 content objects" or "5 content items".
BTW, could you recommend me a good generic name for all types of eZ Publish entities that are possible to create: Content, ContentType, Location, Section, ObjectState, User? Let's assume I have a table with all this entities and would like to give a title for this table.
Monday 27 April 2015 9:56:56 am
I also agree with Peter's commentary.
I personally might (in time) give into using, 'Content Item' but for now I'm still going to use the term, 'Content object', '<content type name when project specific references are made>' where it makes sense for my needs, etc.
That said I think I will try to talk about simply 'content' alone a little more when speaking in general (not about a specific item/object).
I would just sound confusing and a poor speaker (of English) to say, in USA English, 'a content' to people (on my team or to customers).
Friday 25 September 2015 4:54:21 pm
Content is usually contents.
The term content item or item would be more appropriate.
Tuesday 29 September 2015 2:02:47 am
The reason for this change was to avoid the use of the technical term "object" to refer to a content object/item. So I see no problems standardizing for instance Content item(s), I think this is the case already in quite some BDD as we also ended up with issues around this for plural "content".
Side note: Related issue on the API OOP technical side; User now extends Content, which is conceptually wrong, so maybe we need to introduce base type users, user groups and content items all inherit from. Also btw makes it impossible to accomplish the original goal: allowing users to be stored in a user directory.
Saturday 07 November 2015 6:31:41 pm
I also agree without a doubt.
While the new terminology of the new stack was a good move, this unfortunate bad wording came out.
We want to avoid "object" so we will use "items" and as André mentioned, it's been understood and it's now used in many places on eZ Platform and eZ Studio documentation, in BDD, in UX...
Now I am sure there are many 5.x related resources where this is needs to be fixed, I unfortunately don't have a clear view of those.
I'd be very happy if you can point us to those.
I'll discuss with the UX and product team soon, we discussed making an effort to better implement the change. But for the future, yes, it's "content items".
And it will be accepted and understood if people speak about "content objects" or even "content records" in some cases.
You must be logged in to post messages in this topic!