eZ Community » Forums » eZ Publish 5 Platform » still login after logout - production...
expandshrink

still login after logout - production environement

still login after logout - production environement

Monday 22 December 2014 1:49:43 pm - 1 reply

Hi,

I'm using the ezpublish version 2014.07 with the symfony2 frontend stack and I have a problem. I'm still login after a logout when using the production environement.

Here my configurations:

security.yml:

security:
    firewalls:
        [...]
 
        ezpublish_front:
            [...]
            remember_me:
                key: "%secret%"
                lifetime: 31536000
                always_remember_me: true
                remember_me_parameter: _remember_me
                path: /
                name: REMEMBERME
                secure: false
                domain: ~
            form_login:
                login_path: /login
                check_path: /login_check
                target_path_parameter: _target_path
                remember_me: true
             logout:
                path:   /logout
                target: /
                invalidate_session: true

 

When I logout on the dev environement, the response headers looks like:

Cache-Control:no-cache
Connection:keep-alive
Content-Type:text/html; charset=UTF-8
Date:Mon, 22 Dec 2014 10:47:36 GMT
Location:http://xxxxxxxxx.fr/
Server:nginx/1.4.6 (Ubuntu)
Set-Cookie:eZSESSID=f1qli95oq0rumrstcc5t111g92; path=/
Set-Cookie:REMEMBERME=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; httponly
Transfer-Encoding:chunked
X-Powered-By:PHP/5.5.9-1ubuntu4.2

You can see the Set-Cookie:

Set-Cookie:REMEMBERME=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; httponly

 

When I logout on the prod environement, the response headers looks like:

Cache-Control:no-cache
Connection:keep-alive
Content-Type:text/html; charset=UTF-8
Date:Mon, 22 Dec 2014 10:47:36 GMT
Location:http://xxxxxxxxx.fr/
Server:nginx/1.4.6 (Ubuntu)
Set-Cookie:eZSESSID=f1qli95oq0rumrstcc5t111g92; path=/
Transfer-Encoding:chunked
X-Powered-By:PHP/5.5.9-1ubuntu4.2

As you can see, there is no line about the cookie REMEMBERME.

 

In the file web/index.php. It's works fine if I set:

$useHttpCache = false;

 

Has anybody met the same issue ?

Thanks

Wednesday 14 February 2018 10:00:47 am

Hi,
I seem to have the same problem as the one you mention.
What did you do to fix it?
Thanks.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from