eZ Community » Forums » eZ Publish 5 Platform » XML Block Embedded Link clears URL
expandshrink

XML Block Embedded Link clears URL

XML Block Embedded Link clears URL

Tuesday 11 June 2013 5:50:48 am - 10 replies

Hey guys,
I'm having a weird issue whenever I add a link to text in an XML block attribute, the URL I specify is being replaced with "\" when it saves. Even if I disable the eZOE and manually enter the XML/HTML it still removes the URL and replaces it with a "\". I've tried a fresh eZ Publish install on the same server and it still happens. So I've ruled out any eZ Publish settings/overrides etc that I may have messed up. I'm thinking now that it must be a apache/htaccess configuration issue.

I am using the Community Version 2013.1

Any help any of you could provide would be greatly appreciated.

Thanks!

Tuesday 11 June 2013 9:44:49 am

Hi,

Have you try to install a fresh 2013.5 ? It is a lot more stable than 2013.1.

Nicolas

Tuesday 11 June 2013 6:33:14 pm

Hi Guys,

I have the same problem, and it only happens when you try to save or store the draft.

My install is:

  • eZP 5.0.0 using only the ezpublish_legacy
  • PHP 5.3
  • OS: ubuntu 12.10 Linux 3.5.0 i686
  • Web Server: Apache/2.2.22
  • MySQL 5.5.31

 

I upgraded to PHP 5.4 and I still have the problem.

Ernesto

Modified on Thursday 27 June 2013 6:14:53 pm by Ernesto Buenrostro

Wednesday 12 June 2013 2:15:26 am

I haven't tried version 2013.5 yet, but I will. I am also using just the legacy stack.

Wednesday 12 June 2013 10:13:10 am

Hi Wayne

Can you please be a bit more precise on the URL you're trying to add in your XML block ?

Furthermore, can you please try with 2013.5 ?

Thanks

Wednesday 12 June 2013 10:28:35 am

Hey,
I will be trying to install 2013.5 tomorrow. But I'm not holding out much hope as I've installed eZ Publish from the same 2013.1 source on a different server and had no issues. So I'm pretty sure it's a server or apache configuration issue, but I just can't identify what would be causing it.

The issue happens if you edit a node that contains a "XML Block" attribute. I edit the node and click in the eZOE editor for that attribute, I type the text I want to use as a link, highlight the text, click the "Insert/edit Link" button from the eZOE toolbar. A dialog pops up, I select "Http" from the first drop-down, I enter a link, I've been testing with "http://www.google.com.au". I leave everything else as it was. Click "OK", then I "Send for publishing". Now if I re-edit the same node an click the "link" tag from the eZOE's tag breadcrumb, the dialog pops up and the link URL has been changed to "\". Also, if I don't re-edit the same node, but check the database, the new record created in the ezurl table has the URL set as "\". 

I'm guessing when you save your edit to a XML block attribute, some kind of URL transform is applied to links in XML right?

Thanks!

Thursday 13 June 2013 8:23:20 am

Just an update. I have reproduced the issue with version 2013.5 as well.

Monday 15 July 2013 7:39:19 pm

I'm experiencing the same issue with the same setups. It started appearing when i moved the site to a new server. Im still trying to locate what serversettings might be wrong, as i see no other difference in the servers/installations.

Tuesday 16 July 2013 5:21:17 am

The reply has been removed because of violation of forum rules.

Thursday 21 August 2014 2:06:59 pm

Does anyone managed to find out reason of such behaviour ?

I've got the same issue using Community Project 2014.7 on one of my shared hosting server. For sure something is missing in apache/php config, but I don't know what. I just know about php-intl extension missing (pointed out by setup "finetune" ), but I doubt it's connected.

If there is extension missing indeed, is there anything that can be done to replace it ? I'm sure that I've already using eZ Publish older version (4.4) on that server (PHP ver 5.3.28).

 

Thanks for any help

Thursday 15 January 2015 2:15:39 pm

Hi, 

I had the same problem with EZPublish 2014.5. 

The origin of the problem was the functions magic_quotes_gpc (http://php.net/manual/en/info.configuration.php) in php.ini.  Removed in PHP 5.4.0.

If it's enabled on server (see phpinfo.php), all ' (single-quote), " (double quote), \ (backslash) and NUL's are escaped with a backslash automatically. I turn 'off' this function and my problem was solved. 

You can turn off this function on php.ini. If you haven't access to this file : write on your vhost AllowOverride Options or  AllowOverride All, and in htaccess :  php_value magic_quotes_gpc Off

Laura (from ACTI)

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from