eZ Community » Forums » General » Error importing a package from 4.2 to...
expandshrink

Error importing a package from 4.2 to 4.3

Error importing a package from 4.2 to 4.3

Tuesday 09 November 2010 5:19:13 pm - 2 replies

Hi,
I tried to export a node with its tree (class "Gallery"blunk.gif Emoticon from a 4.2 EZ installation, without problems.
When I try to import it in a 4.3 installation (the "Gallery" class is the very same), i get an "Error usng URI:..." error.
The content is imported but can't be installed. I need to import about 5-6 galleries (every one with 50 or more photos), and it will be great if I can avoid to publish them again.
Any suggestion? Thanks!

Tuesday 09 November 2010 7:45:28 pm

Hello Francesco,

The package system work only with 4.3 -> 4.3 or 4.2 -> 4.2 it does not work 4.2 -> 4.3

It recommend only to export packages with the -same- version of eZ Publish.

Cheers,

Heath

Tuesday 09 November 2010 9:13:23 pm

Most of the problems with imprting packages from one version of eZ to another one can be fixed by:

- renaming the package to .tar.gz

- altering the xml files inside with a text editor

- rezipping and renaming

Of course the only though thing is to determine where exactly the problem lies. A couple of versions ago there was a change in (iirc) the allowed chars in package names: uppercase were produced at version X but only lowercase accepted at version X+1 (package name is part of the xml file inside the package itself)

Modified on Tuesday 09 November 2010 9:13:53 pm by Gaetano Giunta

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu