eZ Community » Forums » General » 'ignore_visibility' defaults to true
expandshrink

'ignore_visibility' defaults to true

'ignore_visibility' defaults to true

Wednesday 23 February 2011 11:54:02 pm - 2 replies

I ran into an issue today where books on an author profile page would show up, despite the book being hidden in eZPublish.

After a checking my fetch and then the docs I found that (to my suprise) the 'ignore_visibility' parameters on the 'reverse_related_objects' and 'reverse_related_objects_count' are defaulting to TRUE.

Does anyone have an explanation as to why this is? It seems very odd to me, especially considering that other fetches that support this parameter seem to default to FALSE, as I (and other I've spoken to) would expect.

Would love to find the reasoning behind this.

cheers,
Ben

Modified on Wednesday 23 February 2011 11:55:08 pm by Benjamin Kroll

Thursday 24 February 2011 7:46:02 am

It's because although the 'ignore_visibility' parameter had been set to true, eZ Publish still applies the filter as is defined in site.ini.[SiteAccessSettings].ShowHiddenNodes, so it have a higher priority and you content isn't retrieved.

Could you try to set this parameter to true inside a file override?

Thursday 24 February 2011 5:46:10 pm

Philipp's good memory suggests that it defaults to TRUE for backwards compatibility reasons, because the "reverse_related_objects" fetch didn't used to have an "ignore_visibility" parameter. So I guess it's just one of those "gotchas"!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from