eZ Community » Forums » General » XROWMETADATA. Problem after runing...
expandshrink

XROWMETADATA. Problem after runing runcronjobs.php -sitemap. Please help

XROWMETADATA. Problem after runing runcronjobs.php -sitemap. Please help

Friday 13 November 2015 7:32:20 am - 2 replies

Hi!

I use xrowmetadata extension.

After running  runcronjobs.php -sitemap command, the system reads the default settings from the directory site.ini and cache is stored default settings.

An unexpected error has occurred. Please contact the webmaster.
Unable to connect to the database server 'localhost'
Error #1045: Access denied for user 'root'@'localhost' (using password: NO) in /var/www/vhosts/mysite.com/httpdocs/lib/ezdb/classes/ezmysqlidb.php on line 135

 

 The system no longer uses the settings from my siteaccess, and uses the default settings from site.ini.

The system is working again after the removal of the cache manually

Why is this happening?

I use Parallels Plesk 12.5.

Modified on Friday 13 November 2015 7:39:17 am by Maxim Kopytov

Friday 13 November 2015 8:19:41 am

The problem was solved by creating a file sitemap.sh with code

 #!/bin/bash
cd /var/www/vhosts/mysite.com/httpdocs
./runcronjobs.php sitemap

Modified on Thursday 08 June 2017 7:14:43 am by Maxim Kopytov

Monday 16 November 2015 1:27:03 pm

In past I had the same problem and I resolved without script but with this cronjob lines

$FOLDER = /var/www/vhosts/sitename.example/httpdocs/
 
30 2 * * * cd $FOLDER && php runcronjobs.php sitemap > /dev/null 2>&1

Modified on Monday 16 November 2015 1:28:40 pm by Paolo Gasola

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from