eZ Community » Forums » Install & configuration » 2012.8 php requirement (funny)
expandshrink

2012.8 php requirement (funny)

2012.8 php requirement (funny)

Tuesday 02 April 2013 2:26:20 pm - 3 replies

Hi,

I'm just installing project on preprod for client, which server's php version is 5.2.17. According to download page it should be fine: http://share.ez.no/downloads/downloads/ez-publish-community-project-2012.8

But it's not, I just realized that 2012.8 requires php 5.3.3 - it's clearly visible in kernel/private/classes/ezkernel.php class. But to get nice warning message:

"eZ Publish 5.x does not run with PHP version lower than 5.3."

you need ...... to have php 5.3 ^^, else you will get list of fatal errors instead blunk.gif Emoticon

P.S. Sorry for my black humour, but this mistake in system req spec on download page just put me in huge trouble.

Tuesday 02 April 2013 2:45:12 pm

Hi Bartek, 

Sorry to hear that this caused you trouble. Thanks for pointing this out, I just updated the requirements page accordingly.

Cheers,

Modified on Wednesday 03 April 2013 9:00:47 am by Nicolas Pastorino

Wednesday 03 April 2013 8:53:37 am

Thanks Nicolas, I will now remember it for long time, but as requirements page is modified, it will prevent other developers from mistake.

Finally, client will upgrade his server, so problem will be solved.

 

 

Cheers!

Wednesday 05 June 2013 10:50:58 pm

Hi Bartek,

I was wondering if you had any trouble (other than this one) using the Community version professionally with clients?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from