eZ Community » Forums » Install & configuration » Changing the URL for the language links
expandshrink

Changing the URL for the language links

Changing the URL for the language links

Wednesday 25 January 2012 5:14:38 pm - 3 replies

Hello eZ Community

i am struggeling with a problem in configuration of the multilangue part of my site.

i have two different siteacces i mean i have created one other siteacces except ezwebin which is already installed in my ezpublish.

my site in its current language is nearly finished and i have a french web too ,  

In translation box in top of my site whenever i click on -eng-, it goes to the en site of ezwebin, even the -fre- part goes to french ezwebin. 

i have an error in my log which says :

Tried to find siteaccess based on 'eng-GB' but 'eng'
 is not a valid RelatedSiteAccessList[]

but i cant find how to change it .

my english page's name is: mysite_en i do not want to have maysite/eng/

on the other hand in my language template i have:

<ul>    {if and( is_set( $DesignKeys:used.url_alias ), $DesignKeys:used.url_alias|count|ge(1) )}       

{def $avail_translation = language_switcher( $DesignKeys:used.url_alias )}

    {else}        

{def $avail_translation = language_switcher( $site.uri.original_uri)}  

 {/if}  

 {foreach $avail_translation as $siteaccess => $lang}    

   <li{if $siteaccess|eq($access_type.name)} class="current_siteaccess"{/if}><a href={$lang.url|ezurl}>$lang.text|wash}</a></li> 

    {/foreach} 

   </ul>

in my site.ini i have changed RelatedSiteAccessList[]

SiteURL

SiteLanguageList and everything related to add a siteaccess.

i have read all the forum about multilanguage but i havent found my response

does anyone  have any idea?

Modified on Wednesday 25 January 2012 7:12:49 pm by ray lab

Thursday 26 January 2012 12:28:23 pm

Hi,

Here is the checklist to make this feature works. Make sure that these settings are properly set :

  • SitesSettings.SiteURL at siteaccess level
  • RegionalSettings.TranslationSA at siteaccess level
  • RegionalSettings.LanguageSA at siteaccess or override level
  • RegionalSettings.ContentObjectLocale at siteaccess level
  • SiteAccessSettings.RelatedSiteAccessList at siteaccess level
  • SiteAccessSettings.AvailableSiteAccessList at siteaccess or override level

See my current site.ini file in on of my blog siteaccess in french (blog_fre) :

[RegionalSettings]
Locale=fre-FR
ContentObjectLocale=fre-FR
ShowUntranslatedObjects=disabled
SiteLanguageList[]
SiteLanguageList[]=fre-FR
SiteLanguageList[]=eng-GB
TextTranslation=enabled
# Usage : TranslationSA[siteaccess]=Title
TranslationSA[]
TranslationSA[blog_fre]=Fra
TranslationSA[blog_eng]=Eng
LanguageSA[]
# Usage : LanguageSA[language_code]=siteaccess
LanguageSA[eng-GB]=blog_eng
LanguageSA[fre-FR]=blog_fre

The site.ini file for the related english siteaccess (blog_eng) looks the same, except for :

[RegionalSettings]
Locale=eng-GB
ContentObjectLocale=eng-GB

You can also have different TranslationSA values if you want different labels in the languageswitcher toolbar.

Hope this helps

Arnaud

Modified on Thursday 26 January 2012 12:33:44 pm by Arnaud Lafon

Thursday 26 January 2012 4:55:32 pm

Fantastic! I'd looked for it everywhere! I had'nt found anything! now it works!

thank you verymuch!

Thursday 26 January 2012 5:14:18 pm

You're welcome happy.gif Emoticon

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu