eZ Community » Forums » Install & configuration » CSS Dropdown Top menu Forum
expandshrink

CSS Dropdown Top menu Forum

CSS Dropdown Top menu Forum

Wednesday 28 March 2007 11:14:23 am - 52 replies

This forum is for comments and trouble about the CSS Dropdown Top menu extension on http://ez.no/community/contribs/template_plugins/css_dropdown_top_menu

To Pat - In debug mode, do you see the call to the double_top.tpl
To Sinisa - Could you send me the html output?

Saturday 17 January 2009 1:28:11 am

I think i didn't see it.
with original code, it called: extension/ezwebin/design/ezwebin/templates/menu/flat_top.tpl
with your patch. it called : design/base/templates/menu/double_top.tpl

i work with this step :
1. install ezwebin
2. extract topdrop.tar on root_of_ezpublish\extension
3. add ActiveExtensions[]=topdrop on root_of_ezpublish\settings\override\site.ini.append.php
4. path pagelayout.tpl on root_of_ezpublish\extension\ezwebin\design\ezwebin\templates
5. clear all caches
6. access site using http://localhost/index.php

did i missed something?

Monday 23 March 2009 8:02:33 pm

I'm trying this extension with eZ Publish 4.1 and ezwebin 1.4. It works but side menu disappeared sad.gif Emoticon
Have you any idea how to fix this?

Friday 10 April 2009 12:34:07 pm

Hello,
I started my adventure with eZ Publish 4.1.0 (with ezwebin) few days ago.
Now I would be able to manage drop-down menu with Dropdown Top menu, but I found some difficulties to apply the point 4 of the INSTALL.txt file: in extension/ezwebin/design/ezwebin/templates/pagelayout.tpl I can't find the code to replace

<!-- Top menu area: START -->
<div id="topmenu" class="float-break">
{include uri='design:menu/flat_top.tpl'}
</div>
<!-- Top menu area: END -->

I've got the following Top menu area

<!-- Top menu area: START -->
{if $pagedata.top_menu}
{include uri='design:page_topmenu.tpl'}
{/if}
<!-- Top menu area: END -->

Do I edit the right file?

Thanks in advance.

Sunday 10 May 2009 12:02:51 pm

I've replaced in extension\ezwebin\design\ezwebin\templates\page_topmenu.tpl:

<div id="topmenu-position">
  <div id="topmenu" class="float-break">
    {include uri=concat('design:menu/', $pagedata.top_menu, '.tpl')}
  </div>
  </div>

with

<div id="topmenu-position">
  <div class="float-break">
     {menu name=TopMenu}
 </div>
  </div>

CSS Dropdown Top menu is working but left menu disappeared.

[eZ Publish 4.1 + ezwebin]

Modified on Sunday 10 May 2009 12:03:11 pm by Chris Lyzg

Tuesday 19 May 2009 2:07:42 am

Hi,
I have two questions:
After install on latest EZ publish, I notice that only submenus are visible. The top menu is not clickable. Some top menus do not have submenu and can not be clicked. How is it possible to make the top menu be clickable?
Thank you for your help.
Ali

Tuesday 07 July 2009 10:47:21 am

Hello,

I am using this extension too which is great and works well in IE7 and Firefox but not in IE8. It would be great if someone comes up with a fix!

The only other problem is that the drop items appear behind my main content. It looks like it's one of these classes:
<div id="page-width6"> or
<div id="columns" class="float-break"> or
<div id="main-position"> or
<div id="main" class="float-break"> or
<div class="overflow-fix"> or
<div class="border-box">
I tried palying with the z-index class but no luck.

Has anybody else had this problem or has anybody got any ideas on how I can fix this?

Any help would be much appreciated.

Angelika

Tuesday 07 July 2009 11:03:47 am

I'd like to second Angelika's request for a CSS guru out there to fix the IE8 support. It would be nice to see this great little add on to continue into the future.

Tuesday 07 July 2009 11:11:30 am

Apologies for posting about the order of the menu. After a very long [eriod of trying to fix it, I posted the above thread and minutes later I found the answer! In case someone else has the same problem, I removed the position:relative; property from the class which holds the main content where the menu used to hide behind. It's now working!

Wednesday 15 July 2009 5:19:48 am

Angeliki can you clarify, was the position tag you removed not in the drop down code itself, ie was it unique to your website? I tried removing the position tag within the drop-down and it made things worse.

The only solution I have found so far is to force IE8 into compatibility mode.

Monday 10 August 2009 8:26:14 pm

I replaced in line 33 and 48 like mentioned above in this thread

<!--[if IE 7]><!--></a><!--<![endif]-->
with
<!--[if IE]><!--></a><!--<![endif]-->

and in line 73 to 75 I add
<!--[if lte IE 6]></a><![endif]-->
<!--[if IE 7]><!--></a><!--<![endif]-->
add <!--[if IE 8]><!--></a><!--<![endif]-->
<!--[if !IE]> --><!-- <![endif]-->

works for me with IE 7 and IE 8

happy.gif Emoticon

Friday 15 January 2010 4:06:19 pm

how to patch pagelayout?

I am in v4.2 with ezwebin and I have added

{include uri='design:css_dropdown/page_head.tpl'} just after the {include uri='design:page_head.tpl'} line

and

{include uri='design:css_dropdown/page_topmenu.tpl} just after the {include uri='design:page_topmenu.tpl} line.

In the debug mode I have: Warning: ezjscPacker::packFiles Jan 15 2010 15:16:39 Could not find: stylesheets/css_dropdown.css

My content is:

Folder1

Folder1.1

Folder1.2

Folder2

Folder3

but there are no drop down menu on the mouse rollover Folder1... what is the problem???

Friday 12 February 2010 6:08:11 pm

I cant get the extension to work on 4.2 and webin 1.5

Screen dump:
http://twitpic.com/12soja
Here is what I have done:
- I have unzipped and put the folder "css_dropdown" and its content from
http://ez.no/content/download/169861/1150268/file/css_dropdown.zip into the exentsion folder. I have checked the css_dropdown extionsion in the admin extension on/off menu and cleared cache.
- I have changed extension/ezwebin/design/ezwebin/templates/pagelayout.tpl Deleting whats inside "top menu area start/end" comment and replaced it with:

<!-- Top menu area: START -->
<div class="float-break">
{menu name=TopMenu} </div>

<!-- Top menu area: END -->

This is done according the manual/readme file. Maybe the extension are not uploaded? The extension should be 1.1 but 1.0 is stated in ezinfp.php.

Is it possible the get a precies description on what should bw altered in which file?
Thanks for any help. Looks like a nice exension happy.gif Emoticon distribution and design of navigation is very important and this extension helps..

Modified on Saturday 13 February 2010 11:30:53 pm by Erland Flaten

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from