eZ Community » Forums » Install & configuration » Error 400: Bad Request
expandshrink

Error 400: Bad Request

Error 400: Bad Request

Saturday 21 April 2012 4:46:33 pm - 7 replies

Installation: Community Project 2012.3 in webhosting environment with shell access.

multilanguage siteaccess pol and  eng,with .htaccess (original distribution file without any changes) and with ezflow extension

MatchOrder URI

When I access a website www.novasolspray.pl  and click on "Demo Conntent" logo I get redirection to

Error 400: Bad Request page

If I select any of languages the site function correctly.

Ezpublish is instolled in public root directory like:

/public_root_directory/novasolspray.pl/novasolspray

If  anybody could advise me for what to look for?

Thanks for any help

Peter

Modified on Sunday 22 April 2012 2:43:31 am by Piotr Dabrowski

Monday 23 April 2012 11:34:47 am

When I go  to the URL above, I do not see a full install, so I cannot click on the sample you mention.  In addition, when I go to the languages directly /pol and /eng, I see the same incorrect results..

Have you made changes since posting this query?

Regards,

David 

Modified on Monday 23 April 2012 11:35:07 am by David Ennis

Monday 23 April 2012 4:03:35 pm

Hi David,

I removed demo content since then and slowly started redesigning a site.

Firstly I call the site  www.novasolspray.pl

next when I click on "Novasol Spray" in the header  it will go to "Error 400: Bad Request" page

If I click on any of directories in menu the page will display properly but when I click on "Strona Glowna" (home) it will end up in error page. But if any of languages been selected the site working properly. When error page is encountered the browser path is novasolspraypl/novasolspray if I add to it eng  novasolspray.pl/novasolspray/eng page would resolve.

Looks that there is some problem with resolving "Home"

Modified on Monday 23 April 2012 4:05:29 pm by Piotr Dabrowski

Monday 23 April 2012 9:27:56 pm

Hi there,

Suggestion # 1

I tried http://www.novasolspray.pl/novasolspray/ (using the slash at the end) and it worked fine , but using http://www.novasolspray.pl/novasolspray/index.php  i get a kernel error, so, http://www.novasolspray.pl/novasolspray should show a kernel error at least, so, i think the problem is with the .htaccess default file, could you please try changing the .htaccess file in lines 9, 39

Line 9:

Replace 

RewriteRule ^([^/]+/)?content/treemenu.* index_treemenu.php [L], with RewriteRule ^([^/]+/)?content/treemenu.* index_treemenu\.php [L]

Line 39:

Replace 

RewriteRule .* index.php with RewriteRule .* index\.php

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Suggestion # 2

In the other hand, i think your /settings/override/site.ini.append.php, should be something like this: (please note that this is an example of the default ini after an installation, perhpas the same configuration wouldn´t work for you)

SiteSettings Block

 [SiteSettings] DefaultAccess=pol SiteList[] SiteList[]=ezflow_site SiteList[]=pol SiteList[]=eng SiteList[]=ezflow_site_admin SiteList[]=iphone RootNodeDepth=1 IndexPage=/content/view/full/2/ DefaultPage=/content/view/full/2 SiteName=eZ Flow MetaDataArray[author]=eZ Systems MetaDataArray[copyright]=eZ Systems MetaDataArray[description]=Content Management System MetaDataArray[keywords]=cms, publish, e-commerce, content management, development framework SiteURL= novasolspray.pl

SiteAccessSettings Block

[SiteAccessSettings] CheckValidity=false AvailableSiteAccessList[] AvailableSiteAccessList[]=ezflow_site AvailableSiteAccessList[]=pol AvailableSiteAccessList[]=eng AvailableSiteAccessList[]=ezflow_site_admin AvailableSiteAccessList[]=iphone MatchOrder=uri HostMatchMapItems[] 

You can also check this forum http://share.ez.no/forums/developer/hostmatchmapitems-default-siteaccess

I will be pending if this fails to suggest a better option.

Regards,

Modified on Monday 23 April 2012 9:29:21 pm by Diego Amaya

Monday 23 April 2012 9:32:37 pm

Hi,

I think you could try also adding this to your /settings/override/site.ini.append.php in the [SiteAccessSettings] block

HostMatchMapItems[]=novasolspray.pl;pol

Please be sure that pol is the siteaccess name you are using currently.

Tuesday 24 April 2012 1:40:08 am

Hi Piotr,

I think, you could also add this on the [SiteAccessSettings] block for the main siteaccess site.ini, in case the solutions proposed above doesn´t work.

[SiteAccessSettings]

.........

.........

MatchOrder=uri

URIMatchType=map

URIMatchMapItems[]

URIMatchMapItems[]=novasolspray;<put here the name of your main siteaccess>

ForceVirtualHost=true

Modified on Tuesday 24 April 2012 1:40:38 am by Diego Amaya

Tuesday 24 April 2012 11:59:08 am

Hi Diego,

Thanks for your help.

I tried all suggestions but unfortunately nothing work.

I've done some experiment. I removed this rule:

RewriteRule .* index\.php

When I went to the site and click on "Novasol Spray" it work but anything else did not.

Browser path was showing: www.novasolspray.pl/novasolspray/

normally coming without   /

Modified on Tuesday 24 April 2012 11:59:39 am by Piotr Dabrowski

Sunday 29 April 2012 3:09:46 pm

I've made some progress on this issue. I added a line into .htaccess

RewriteRule !(\.(gif|jpe?g|png|css|js|html?)|var(.+)storage.pdf(.+)\.pdf)$ index.php

and commented out

#RewriteRule .* index.php [L]

in this case my site working correctly but when language is selected I will get an

error, kernel (20) module  "pol" or "eng" cannot be found.

When I uncomment rewrite rule below  site will go to original condition with Error 400 pages

RewriteRule .* index.php [L]

and languages will resolve correctly. So I'm  lost at the moment.

Modified on Sunday 29 April 2012 3:14:10 pm by Piotr Dabrowski

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from