eZ Community » Forums » Install & configuration » Fatal error: Maximum execution time...
expandshrink

Fatal error: Maximum execution time of 30 seconds...

Fatal error: Maximum execution time of 30 seconds...

Sunday 07 May 2006 5:34:25 pm - 29 replies

I install all and i don' t know what' s this...
Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/ezpublish-3.6.4/lib/ezxml/classes/ezxml.php on line 302
Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below.
this is menssage paear when i try to enter in my website ez the first time!!!

Help me please!!
Thank' s sorry for erros about english because im brazilian!!!

Modified on Monday 08 May 2006 8:16:33 am by lucas santos

Monday 08 May 2006 8:10:53 am

Hello Lucas

Welcome to the eZ publish community!

You will find a solution for your problem here: http://ez.no/community/bugs/fatal_install_error (first comment).

Monday 08 May 2006 8:13:36 am

You should increase the maximum execution time for PHP. You can do it by changing the php.ini file. Change this line:

max_execution_time = 30

and set the value of at least 120. It could also be usefull to increase the memory limit:

memory_limit = 8M

to at least 256M. (also in php.ini)

If this doesn't solve the problem then try getting a faster computer happy.gif Emoticon

Monday 07 May 2007 12:43:07 pm

Or ask your IT host provider for help, not always users can help themselves with that problems, but it is really simple to fix that annoying problem, the user before me told You what to do.

Sunday 17 June 2007 4:23:29 am

I'm trying to install eZ Publish 3.9.2 on my local PC.

Installation Package: ezpublish-3[1].9.2_installer.exe
OS: Windows XP
CPU: 500M Intel Celeron
Memory: 256M

I meet the similar problem:

Fatal error: Maximum execution time of 600 seconds exceeded in c:\...\xxx.php on line xxx
Fatal error: eZ publish did not finish its request

I use xxx because the file name and the line number is different every time while I install.

I change the php.ini to

max_execution_time =3600
max_input_time = 600
memory_limit =64M

 

But it's no efect.

Any help will be deeply appreciated.

<b>Thanks!</b>

Modified on Sunday 17 June 2007 4:26:48 am by Jianjun Hu

Sunday 17 June 2007 2:53:16 pm

You need to restart / refresh Apache so that the setting has any effect usually.
In Windows this can be a bit tricky sometimes on some setups, so last resort is to restart Windows...

Since you have a fairly slow (by today's standards) CPU, the installation can take quite some time. But you could try to install plain_site instead since it doesn't take as much time as the website interface install ( webin creates a lot of content and copies it to the selected languages, adds the ezwebin extension and adds / changes some classes while installing ).

EDIT: 500 Mhz is a bit to shabby for eZ Publish, especially under Windows where everything is at least 2x slower ( reasons: Apache 1.3x not optimized for windows, Windows is a bit slow on process creation and NTFS is a slow file system). Anyway you might have better luck with eZ Publish 4.x on slow computers, it is sometimes 2-4x faster then eZ Publish 3.x thanks to PHP5.

Modified on Tuesday 15 January 2008 1:58:41 pm by André R

Monday 18 June 2007 8:53:29 am

Thanks, André R.

I restarted windows in order to refresh apache according to your suggestions but on effect. Maybe my computer is too old to run this program.

I have installed the eZ Publish 3.9.2 on a better linux computer successfully. Thanks again for your help.

Tuesday 14 August 2007 2:02:01 am

I installed ez publish (with the ezwebin extension) on my dev box at home.
the mighty beast is
700mhz athlon cpu
256mb memories
debian etch (although the sticker on the box says it can run the awesome windows 98se)

120secconsd wasnt enuff for me but i installed it and it runs with
180secconds exec time
64mb memory limit

post install each request takes aprox 1-1.5 secconds
and it can serve 20 pages in about 22 secconds

Saturday 17 November 2007 12:31:58 am

There's something wrong with the Windows installer... (ezpublish-3.10.0_installer.exe)

max_execution_time =3600  
max_input_time = 3600
memory_limit =600M

and still no go... and on a pretty recent Core 2 Duo with 1GB of RAM
also the php.ini is placed in the root windows folder...

Cancel that... a different error appears after changing the php.ini settings.

Modified on Saturday 17 November 2007 12:38:48 am by Leszek Jakubowski

Monday 17 March 2008 12:25:25 am

I'm trying to install <b>eZ Publish 4.0.0</b> on my local PC.

CPU: Core Duo T2050 1.6GHz
Memory:2G
OS: Windows XP
XAMPP1.6.3a
--Apache 2.2.4
--PHP 5.2.3
--MySQL 5.0.45

The related configulations in php.ini is

max_execution_time = 6000
max_input_time = 600
memory_limit = 256M

I checked the <b>'max_execution_time'</b> with <b>phpinfo()</b>. The 'max_execution_time' is <b>6000</b> !

I meet the problem when I install.

Fatal error: Maximum execution time of 600 seconds exceeded in ...\xxx.php on line 525
Fatal error: eZ publish did not finish its request

I checked the 'max_execution_time' with phpinfo() again, it remained <b>6000</b> ! But why the error information displays <b>600</b>?

I was disturbed about the problem for several days. Help me please!

Thanks!

Modified on Monday 17 March 2008 12:26:34 am by Jianjun Hu

Friday 07 November 2008 6:13:16 pm

Greetings.
Nothing else for me but add a comment to this post.
Trying to install eZ Publish 4.0, and haven't been able to do it with the "Website Interface (ver. 1.3-1)" (will have to try the "Plain site"blunk.gif Emoticon.
Everything seems right. When I get to the "Site registration" section, this is what "Comments" shows:

Site info:

  Site package  - ezwebin_site
  Title         - Website Interface XXX
  URL           - http://localhost/ezpublish/index.php/ezwebin_site
  Admin URL     - http://localhost/ezpublish/index.php/ezwebin_site_admin
  Access type   - url
  Access value  - ezwebin_site


Web server info:
Version - Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4

PHP info:
Version - 5.2.4

OS info
Name - Windows NT BELG-II 5.1 build 2600

Database info:
Type - PostgreSQL
Driver - ezpostgresql


Email info:
Transport - SMTP

Image conversion:
ImageMagick was found and used.
Path - c:\program files\imagemagick
Executable - convert.exe
ImageGD extension was found and used.

Regional info:
Primary - eng-US
Additional - fre-FR, ita-IT, eng-US

Critical tests

directory_permissions - Success
phpversion - Success
database_extensions - Success
image_conversion - Success
open_basedir - Success
safe_mode - Success
memory_limit - Success
execution_time - Success
magic_quotes_runtime - Success
allow_url_fopen - Success
accept_path_info - Success
php_session - Success
file_upload - Success
zlib_extension - Success
dom_extension - Success
timezone - Success

Other tests:

php_magicquotes - Success
mbstring_extension - Success
imagegd_extension - Success
imagemagick_program - Success
database_all_extensions - Success
php_register_globals - Success
texttoimage_functions - Success

I did uncheck "Send registration" so it would take less time.

XAMPP shows these lines for the Configuration - PHP Core:

max_execution_time	3600	3600
max_input_nesting_level	64	64
max_input_time	60	60
memory_limit	512M	512M

My values for the php.ini Apache file is:

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 3600     ; Maximum execution time of each script, in seconds
max_input_time = 60	; Maximum amount of time each script may spend parsing request data
memory_limit = 512M      ; Maximum amount of memory a script may consume (16MB)

Being like that and all, I keep getting this error:

Fatal error: Maximum execution time of 600 seconds exceeded in C:\xampp\htdocs\ezpublish\lib\ezdb\classes\ezpostgresqldb.php on line 168

Fatal error: Maximum execution time of 600 seconds exceeded in C:\xampp\htdocs\ezpublish\lib\ezutils\classes\ezexecution.php on line 144

I'm not sure if I'm missing some pre-install configuration step, or it's just that my PC is too slow for eZP.

MS Windows XP, Home Edition, Version 2002, SP3.
Intel Celeron CPU 2.40GHz
2.39 GHz, 1.49 GB of RAM

Maybe the answer is around this forum, but haven't found it yet.
This error is pretty disturbing, though.
Hope can get some help and solve this error.

ß.

Friday 07 November 2008 7:21:37 pm

@Bernardo

If that celeron is also your desktop PC forget it. You need more power, I guess.

Friday 07 November 2008 7:35:42 pm

@ Björn Dieding@xrow.de

Thanks so much for the prompt answer.
I was affraid it was something like that. I guess now I have more to add to Santa's list.

Best regards.

ß.

Wednesday 07 January 2009 3:16:14 pm

I am having similar issues with changes to php.ini. I was following the idea that it is perhaps my PHP installation on Vista is virtualizing the php.ini file until I read the posts above. They are having the same issue using XP.

Now I will look to see if the PHP handler is even seeing the one copy of php.ini on the disk. Renaming it and trying after a reboot would let me know a lot about what might be causing this issue.

My error occurred during the admin login, after a fully successful installation. I will "report back" soon.

Wednesday 07 January 2009 4:24:17 pm

Well here is the answer to all of you who are seeing no changes to their php installation when they have obviously made a change to the php.ini file.

The PHP installation looks for the php.ini file in you windows root directory. In most cases that would be "C:\WINDOWS". I went to http://php.net and searched on "trouble windows php.ini" for all "php.net sites" and took the second listing there. This is the direct link to the discussion there.

http://php.net/manual/en/install.windows.iis.php

Hopefully this will help you with the time zone settings as well as the timing and memory allocation entries.

Modified on Wednesday 07 January 2009 4:31:49 pm by Chris Pergantis

Wednesday 07 January 2009 5:06:49 pm

ALWAYS create a info.php with a call to phpinifo(); to see what php.ini is used, different packages use different files ( wamp for instance does not use the one in c:/windows/, but in the case of wamp, use the menu in your taskbar to open the correct php.ini).
AND remember that a different setting file is used for CLI (command line version of php).

PS: Make sure there is no obvious way to reach the 'phpinfo.php' on a public server, or better yet remove or secure it..

Wednesday 07 January 2009 6:48:19 pm

One more point for those of you who are Vista with UAC turned on. The file php.net was difficult to change to the new content/settings for the PHP system.

In order to make the change I opened php.net in the text editor. I then made those changes and saved the file as php.net.txt on my desktop.

In the Start pop up menu of Windows Vista there is an entry field called "start search". I typed the "php.ini" into that field. I then deleted all files showing in that search results and ignored all that appeared in the search result which did not match exactly "php.ini".

I then rebooted, rechecked the same search and then I opened my copy of php.ini.txt on my desktop in the text editor. I did a "save as" from the text editor and confirmed all of the UAC messages. I then shut down the text editor.

I redid the search again and hopefully at this point you would see two entries in the result of that search. Each will be "php.ini.txt". One of those files will be the one on your desktop the other will be in the "c:\windows" directory. I then right clicked on the one in the "c:\windows" directory and dropped down to the "open file location" choice. The window that opened had the file highlighted. I renamed that file to "php.ini".

I am sure there might have been an easier way to do this but it was a trial and error for my process. Those of you who don't have to deal with UAC just don't understand even though you may have some thread of compassion.

I hope this helps......

Sunday 14 June 2009 2:42:48 pm

The reply has been removed because of violation of forum rules.

Thursday 25 June 2009 9:55:05 am

The reply has been removed because of violation of forum rules.

Tuesday 13 April 2010 1:28:21 pm

I currently have the following configured in my PHP.ini (according the eZ Publish system information):

Script memory limit is 256M.
Maximum execution time is 7200 seconds.

Still, when I upload a package of 24kb the processor is at 100% for two hours until it gives the time out error.

I seriously doubt the php settings are the solution, as it should never need so much resources to unpack a very small package.

Any ideas?

Tuesday 13 April 2010 2:54:58 pm

Usual advice applies.

1. Check your php.ini

2. Create a phpinfo() file and check that the values you think are set in php.ini actually show up in the file are the same, if not then phpinfo() will tell you the real location of you php.ini file.

3. Restart apache

4. Check permissions of your var directory

5. If you receive white screens during installation your script ran out of memory, increase script memory limits in php.ini

6. If you run into timeout issues during at the package selection screen of the installation process there is a good chance your system can't remotely fetch packages.

7. If you run in timeout issues at language selection in installation just upgrade.

8. If you receive high CPU usage and timed out scripts in eZ Publish 4.2 or lower try using 4.3, this can occur when trying to instantiate a new object through eZContentClass without a valid user (ugly ugly problem which is resolved in 4.3). You shouldn't see this unless you are installing sso handlers or other extensions that drop in before users are set.

9. Don't use Windows, are you asking for trouble?

10. Unless you are specifically supporting a client on an older version - there is no real excuse for running anything more than 2 general releases old. You should be using 4.2 or 4.3 now.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu