eZ Community » Forums » Install & configuration » LDAP authentication (working on admin...
expandshrink

LDAP authentication (working on admin page)

LDAP authentication (working on admin page)

Tuesday 02 December 2014 3:20:27 pm - 4 replies

Hello everyone,

I'm trying to set up the LDAP authentication on my front-end website : only the employee from my company should access to the website content.

The LDAP authentication is working in the "_admin" part (back-end) but with the same login/pwd, I have the error :

Could not login

A valid username and password is required to login.

I tried setting up :

 

[UserSettings]
LogoutRedirect=/
LoginHandler[]
LoginHandler[]=standard
LoginHandler[]=LDAP

In the site.ini.override.php of my front-end website but it's not working...

 

Thanks

Friday 12 December 2014 12:27:19 pm

Hi Martin,

are you sure that the user actually has access to the front-end siteaccess?

Friday 19 December 2014 1:53:11 pm

Hi Håvard,

Yes, my LDAP rule add the user in a news groupe inside the "Administrator Users". So my user is Administrator of the whole solution (and so have access to all websites)... Am I right ?

Thanks,

Friday 19 December 2014 2:43:23 pm

Yes, that is correct - the user should have access so that can't be the problem. 

Have you tried enabling the debug output/checking the var/log/ for clues? Or you could try to var_dump the different variables in kernel/user/login.php to see if that can point you in the right direction.

Sorry that I can't be of more help than this, but it is difficult to debug without knowing how the system is configured happy.gif Emoticon

Monday 29 December 2014 4:57:45 pm

Hi Håvard,

I enabled the debug output but I have no log errors about this login.
Are you sure that this file : ezpublish_legacy/kernel/user/login.php is used in the front interface ? When I do a var_dump("123"blunk.gif Emoticon; in this file, I have it when I want to log to the admin interface but I don't have it when I try to log in the front end website...

Thanks

Edit : I'm using the 2014.7 version of ez publish...

Modified on Monday 29 December 2014 5:02:30 pm by Martin M

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from