eZ Community » Forums » Install & configuration » Templates used in html, how to turn off
expandshrink

Templates used in html, how to turn off

Templates used in html, how to turn off

Wednesday 24 December 2014 9:24:40 am - 3 replies

Hello,

I have a problem with eZ dispalying which tempate is used in html also. Like this:

<!-- START: including template: design/bohemen/override/templates/content/datatype/view/ezselection.tpl (design:content/datatype/view/ezselection.tpl) -->
  Fotball
  <!-- STOP: including template: design/bohemen/override/templates/content/datatype/view/ezselection.tpl (design:content/datatype/view/ezselection.tpl) -->
 

I have searched for a configuration switch to turn this off, but cannot find it. I really need to get rid of this for the page to render correctly.

Any ideas? These are my current debug/template settings, i have tried to alter them all:

[TemplateSettings]TemplateCache=disabledTemplateCompile=disabledTemplateOptimization=disabledDebug=enabledShowUsedTemplates=enabled#TemplateCache=enabled#TemplateCompile=enabled#TemplateOptimization=enabled#Debug=disabled#ShowUsedTemplates=disabled# ShowXHTMLCode=enabledShowXHTMLCode=disabled
[DebugSettings]DebugOutput=enabledDebug=inlineDebugRedirection=enabled#DebugOutput=disabled#DebugRedirection=disabled#QuickSettingsList[]=DebugSettings;DebugOutput;site.ini;Debug output#QuickSettingsList[]=DebugSettings;DebugRedirection;site.ini;Debug redirection#QuickSettingsList[]=TemplateSettings;Debug;site.ini;Template debug#QuickSettingsList[]=TemplateSettings;ShowXHTMLCode;site.ini;Inline template de\bug#QuickSettingsList[]=TemplateSettings;ShowUsedTemplates;site.ini;List of used t\emplates#QuickSettingsList[]=DatabaseSettings;SQLOutput;site.ini;SQL debug output

Any ideas anyone?

 

Regads,

Atle

Wednesday 24 December 2014 9:29:50 am

Ok, that became messy... I try again...

site.ini.append.php:

[TemplateSettings]

TemplateCache=disabled

TemplateCompile=disabled

TemplateOptimization=disabled

Debug=enabled

ShowUsedTemplates=enabled

#TemplateCache=enabled

#TemplateCompile=enabled

#TemplateOptimization=enabled

#Debug=disabled

#ShowUsedTemplates=disabled

# ShowXHTMLCode=enabled

ShowXHTMLCode=disabled

[DebugSettings]

DebugOutput=enabled

Debug=inline

DebugRedirection=enabled

#DebugOutput=disabled

#DebugRedirection=disabled

#QuickSettingsList[]=DebugSettings;DebugOutput;site.ini;Debug output

#QuickSettingsList[]=DebugSettings;DebugRedirection;site.ini;Debug redirection

#QuickSettingsList[]=TemplateSettings;Debug;site.ini;Template debug

#QuickSettingsList[]=TemplateSettings;ShowXHTMLCode;site.ini;Inline template de\bug

#QuickSettingsList[]=TemplateSettings;ShowUsedTemplates;site.ini;List of used t\emplates

#QuickSettingsList[]=DatabaseSettings;SQLOutput;site.ini;SQL debug output

The inline html pasted in the above message wo'nt display properly here in the forum or let me alter it to format properly suspicious.gif Emoticon Sorry for that.

Regards, Atle

Wednesday 24 December 2014 6:56:43 pm

Hello Atle,

The default is to have this debug disabled.

So you could remove your TemplateSettings site.ini override block settings or simply set Debug=disabled

This should solve this problem. Remember to clear ini caches (at least).

I hope this helps!

Cheers,
Heath 

Monday 29 December 2014 7:07:08 am

Thanks again, Heath happy.gif Emoticon

 

Regards, Atle

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from