eZ Community » Forums » Install & configuration » weird behavior of creating new...
expandshrink

weird behavior of creating new objects // user rights

weird behavior of creating new objects // user rights

Wednesday 09 April 2014 12:08:40 pm - 3 replies

hi ez-fans,

i got a little problem with my user rights / roles.

 

Situation:
User X and User Y are in the same role with the same options.
User X was created in 2013. User Y was created last week (04/2014).
Between these years i created a new class and a new directory for the class.
User X CAN NOT create new objects (its disabled). User Y CAN create objects.
so it works generally for some users.

 

What did i try?
Created a new user with the same role => user can create a new object
behaveiour is the same in different browser and differnt pcs. => no client, server setting
Delete user's cms cookies => user / role rights are not in cookie => no client, server setting
Users are in only one group "editors" with same rights.
Delete three caches in "setup"->"cache management":  Browser cache, userinfo cache, restriction cache (dont' know what the english names are. admin is in german)
 
any idea is welcome. thank you.

Modified on Wednesday 09 April 2014 12:12:22 pm by tobi f

Friday 11 April 2014 2:24:47 pm

Wow, nice, this sounds like a genuine bug to me happy.gif Emoticon

Could you give more details about the policies applied to those users, especially in terms of content class limitations on content/create (but not only) ?

Did you try editing & re-publishing a user that is currently unable to create objects ?

I'm thinking the list of allowed classes is for some reason stored somewhere in the policies, and wasn't updated for this user. But it's a pure hunch.

Wednesday 16 April 2014 11:08:11 am

Quote from Bertrand Dunogier :

Did you try editing & re-publishing a user that is currently unable to create objects ?

you did it, bertrand. Thank you so much. finally it works with that easy fix.

i just republished the old users and now the "create new " buttons appers.

 

That "bug" means that the old policies are stored with the user/objects in the database, right?

do you know if there is something like a "republishing/refreshing" cronjob / skript that i can trigger once a day?

 

 

 

 

Modified on Wednesday 16 April 2014 11:08:33 am by tobi f

Tuesday 22 April 2014 11:06:00 am

Either database, or cache... you mentioned that you cleared various caches, but I'm not sure you tried to clear all caches.

After browsing a bit, I'd be very surprised if it was stored in the database. Sounds like a cache issue to me.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from