eZ Community » Forums » Setup & design » allow a user to contribute to a forum
expandshrink

allow a user to contribute to a forum

allow a user to contribute to a forum

Wednesday 20 February 2013 12:14:09 pm - 7 replies

Hi everybody,

I have created a forum using the "forums" and "forum" classes.

Everything works fine when I am connected as an admin.

It get worse when I try to acces the forum connected as "anonmous", I manage to acces the list of discussions of the "forums" class, but when I try to access to a discussion I got a message "you need to authentified to contribute the forum".   (

I guess I need to define a user policie on the anonymous role.

Do you know how to define it?

thanks for your help

regards

FA

Modified on Wednesday 20 February 2013 12:22:48 pm by fabien angelier

Wednesday 20 February 2013 12:31:18 pm

Hi Fabien!

First, are your forum and forum posts published in the standard section? If yes, by default anonymous user can access to this section.

If you want to add a policy to an user or groups, you have to go in your admin interface, user tab and click on the "Rules and policies" link (bottom of left menu). 

 

Cheers.

Wednesday 20 February 2013 1:18:18 pm

hi thanks for your fast answer

the forum and forum posts are both in the standard section.

find below the policies for the anonymous role:

content pdf Section( Standard )
content read Section( Standard )
content read Class( Fichier , Animation Flash , Image , Forum , Forums , Contenu Multimedia , Fichier vidéo , PLV , Direction , Quicktime , Windows media , Real video , Banner )
rss feed No limitations
user login SiteAccess( bdaf )

Wednesday 20 February 2013 1:36:39 pm

In your rule content/read Class( Fichier , Animation Flash , Image , Forum , Forums , Contenu Multimedia , Fichier vidéo , PLV , Direction , Quicktime , Windows media , Real video , Banner ), you don't have the class Forum topic and the class Forum reply in the definition.

Can you add them and try again?

Cheers.

Wednesday 20 February 2013 1:56:56 pm

I have selected all the classes for the "read" rule, the result is still the same:

I manage to list the subject item of the forum:

Objectif 165

Forum

Sujets

Messages

Dernière réponse

Réussir le PAC 2013 0 0  
Le maillage du territoire 0 0  
La préparation de l'e-agence 0 0  
La banque à distance 0 0  
Le plan de conquête 2013-2014 0 0  
Process crédits aux professionnels et entreprises 0 0  
Gestion des epèces 0 0  
Mise en place du système de mesure de la qualité des process 0 0  
Lien avec le PIA 0 0  
Plan de formation managériale 0 0  
Mise en place d'un tableau de bord opérationnel 0 0  
Orgnaiser les 160 ans de la banque 2 3

Forum des métiers

15/02/2013 10:46

Etude d'appréciation des clients et plan d'actions 0 0  
Organiser la fonction communication de la banque

but when I try to acces one of the item, I am asked to login:

 

Sujet

Réponses

Auteur

Dernière réponse

Vous devez être identifié(e) pour participer aux forums. Pour cela, cliquez ici.

Wednesday 20 February 2013 2:34:57 pm

If you want to allow anonymous users to post, you have to add the policy:

content/create Class(Forum topic, Forum reply) ParentClass(Forum)

 

Cheers.

Thursday 21 February 2013 6:09:33 am

It works!!!!!!!!!!!

cheeeeeeeeeeeeeers Sylvain

Thursday 21 February 2013 8:06:42 am

Glad to hear that!

Could you mark the question as resolved?

Cheers.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from