eZ Community » Security Advisories » EZSA-2019-001: XSS in Admin UI

EZSA-2019-001: XSS in Admin UI

Publication date : 12/03/2019
Severity : High
Affected versions : eZ Platform 2.x, specifically ezsystems/ezplatform-admin-ui v1.3.x and v1.4.x, and ezsystems/ezplatform-page-builder v1.1.x and v1.2.x.
Resolving versions : ezsystems/ezplatform-admin-ui v1.3.5 and v1.4.4, and ezsystems/ezplatform-page-builder v1.1.5 and v1.2.4

This security advisory fixes a severe vulnerability in the eZ Platform Admin UI, and we recommend that you install it as soon as possible. Parts of the Admin UI are vulnerable to XSS injection. All 2.x sites are at risk, and particularly those that allow user generated content. The update adds the necessary escaping of injected code. This resolves the issue both for code that has already been injected, and any future such code.

To install, use Composer to update "ezsystems/ezplatform-admin-ui" and "ezsystems/ezplatform-page-builder" to one of the "Resolving versions" mentioned above. (ezplatform-page-builder exists only in eZ Platform Enterprise Edition.)

This issue was reported to us by Thomas Poskocil, MSc of Radarservices Smart IT GmbH, a technology company in the field of Detection & Response. We are very grateful for their research, and responsible disclosure to us.

If you come across a security issue in our products, here is how you can report it to us: https://doc.ez.no/Security

36 542 Users on board!

Community Project menu

Proudly Developed with from