eZ Community » Forums » Developer » Cache-block problem on shared hosting
expandshrink

Cache-block problem on shared hosting

Cache-block problem on shared hosting

Tuesday 07 May 2013 12:26:15 pm - 4 replies

Hi guys,

We have a small problem with cach-block on shared hosting (only shared).  For example we have a small cache-block with short expiry time:

 {cache-block expiry=600 keys=array( $uri_string ) ignore_content_expiry}

The problem is, that this cache-bloch doesn't expire after 10 minutes and it serve old content. It works correctly on my vm with debian. eZ Publish v. 4.x Any suggestion?

Modified on Tuesday 07 May 2013 12:37:49 pm by Radek Kuchta

Tuesday 07 May 2013 1:41:17 pm

Hi Radek,

Are you sure that this block is not part of some other cache?

For example on the hosting you enabled view cache (which you have probably disabled on your local machine)

Tuesday 07 May 2013 2:23:11 pm

Hi Ivo,

I have the same cache configuration for shared and local server. View cache is enabled and works correctly on both server. Also DevelopmentMode is disabled. There is a problem only with cache-block in template which is included as a parts to pagelayout (it is not inside a view cache).

Tuesday 07 May 2013 2:29:48 pm

Quote from Radek Kuchta :

I have the same cache configuration for shared and local server. View cache is enabled and works correctly on both server. Also DevelopmentMode is disabled. There is a problem only with cache-block in template which is included as a parts to pagelayout (it is not inside a view cache).

Ok, that does look really awkward. 

What happens if you remove ignore_content_expiry and publish some content? Does it work then?

Tuesday 07 May 2013 2:41:53 pm

Quote from Ivo Lukač :

What happens if you remove ignore_content_expiry and publish some content? Does it work then?

I will try and do some tests. Thanks for suggestion.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from