eZ Community » Forums » Developer » Can't display nodes ---
expandshrink

Can't display nodes ---

Can't display nodes ---

Sunday 18 May 2003 7:56:43 am - 4 replies

Can't really explain why, in {let} '265' is parent node id, '33' is class id what i want to display. nation(class id 33) is my class that desc nation information.

I want to display only nation information.
There is many element in parent node(265), link, articals and nation(my class), but i want to nation class to display
please...............

It's my source code in file line_class_33.tpl
-----source code-----
{* set children variable *}
{let childen=fetch('content',list,hash(parent_node_id ,265 ,class_filter_type, include, class_filter_array, array(33)))}

{* loop children and show line view *}
{section name=Child loop=$children}
{node_view_gui view=line content_node=$Child:item.name}<br>
{/section}

{/let}

Modified on Sunday 18 May 2003 8:03:05 am by bs jeong

Sunday 18 May 2003 10:54:49 am

Have you checked that the Anonymous user role allows you to view your new class? By default it doesn't allow this.

Paul

Modified on Sunday 18 May 2003 10:55:00 am by Paul Forsyth

Monday 19 May 2003 3:41:03 pm

Thank you Paul..

Yes....
Anonymous user role checked that the Anonymous user role allows read all class - content read *
Is my source code ok???
read change read all classHave you checked that the Anonymous user role allows you to view your new class? By default it doesn't allow this.

Monday 19 May 2003 4:08:29 pm

Not sure, your fetch line looks fine. Have you tried to look at the array produced to see if it contain anything using

{$children|attribute(show)}

It might be a problem with your line_view...

The other day I tried using a latest trunk version of ez3 and i had a similar issue in that my fetch simply wouldnt return any objects of my new class. Editing the roles gave me weird results and in the end i went back to using the stable branch. Not sure if this applies to you but thought id mention it.

Paul

Monday 19 May 2003 8:46:03 pm

Using |attribute(show) I see my Folder has an array, but no children. I suspect the Articles in my Folder are not children, therefore fetch(...parent_node_id) does not find them because without being children they can not have parents. I haven't found the definition of what is child of what, but you might look at your items for this.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from