This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Developer » error in redirection to login page
expandshrink

error in redirection to login page

error in redirection to login page

Tuesday 12 November 2013 12:04:01 pm - 2 replies

Hello , 

When my site members, receive a notification email from a private section, if they are not logged in to website, they got an error (instead of redirect to login page):

The page cannot be displayed

Technical Information (for support personnel)

  • Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL). Contact the server administrator. (12202)

 

 

I cannot find how to modify it.

 

Can anyone help me please? 

Thanks in advance

Modified on Wednesday 13 November 2013 9:29:19 am by nazanine ahmadi

Thursday 14 November 2013 2:37:10 pm

Hi , 

As the problem, seemed to be a problem from the server for me, in my virtual host i change directory from var/www/mysite/web to var/www/mysite/mysite_legacy.


It works fine for me but i want to keep  /web in directory adresse.

Now i know where it comes the problem but i cant understand WHY and how to resolve it.

As I knew, index in web folder is just a shortcut of the real index. so mysite_legacy and web should be just the same.

  
 
RewriteEngine On RewriteBase /
 
RewriteRule ^api/ index_rest.php [L]
 
RewriteRule ^index_rest\.php - [L]
 
RewriteRule ^([^/]+/)?content/treemenu.* index_treemenu\.php [L]
 
RewriteRule ^var/([^/]+/)?storage/images(-versioned)?/.* - [L]
 
RewriteRule ^var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
 
RewriteRule ^design/[^/]+/(stylesheets|images|javascript)/.* - [L]
 
RewriteRule ^share/icons/.* - [L]
 
RewriteRule ^extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]
 
RewriteRule ^packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
 
RewriteRule ^packages/styles/.+/thumbnail/.* - [L]
 
RewriteRule ^var/storage/packages/.* - [L]    
 
RewriteRule ^/favicon\.ico - [L]    
 
RewriteRule ^/design/standard/images/favicon\.ico - [L]
 
<span>RewriteRule var/ezwebin_site/storage/original/application/.* - [L]</span>
 
RewriteRule ^robots\.txt - [L]
 
RewriteRule ^Sitemap.xml - [L]
 
RewriteRule ^BingSiteAuth.xml - [L]
 
RewriteRule ^w3c/p3p\.xml - [L]
 
RewriteRule .* index\.php 
 
# v1 rest API is on Legacy
 
RewriteRule ^/api/[^/]+/v1/ /index_rest.php [L]
 
<span>RewriteRule ^/bundles/ - [L]</span>
 
<span>RewriteRule ^/css/.*\.css - [L]</span>
 
RewriteRule ^/js/.*\.js - [L]

Wednesday 04 December 2013 6:41:52 pm

This is still an issue,

Can anyone help please?

Just before logging into the site, at the very first time that I click on a private link, I see a "403" page!

I don’t have any error in my logs (apache / ezpublish).

When i refresh the page, page reloads in a correct way, this started to work, only when I change the directory from /web to ezpublish-legacy. (Before it was permanently on 403.)

I cannot really understand what is happening in the background. I have searched everywhere but I haven’t found anything.

So if I would appreciate if someone could just help...

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from