eZ Community » Forums » Developer » Ez Find & Search.tpl cache problem
expandshrink

Ez Find & Search.tpl cache problem

Ez Find & Search.tpl cache problem

Thursday 21 April 2011 11:34:36 am - 2 replies

 

Hi,

I created new extension and i overrided ez find default search.tpl into myextension/mydesign/myextension/templates/content/seach.tpl.

When I try to perform search I have always the same result, result seems to be cached.

I tried to place this code into the header of search.tpl template :

{set-block scope=root variable=cache_ttl}0{/set-block}

but there is no effect, the search result is always the first research.

Do you have any idea where the problem might come from ?

Modified on Thursday 21 April 2011 11:36:53 am by Jérémie Caulier

Thursday 21 April 2011 5:49:35 pm

Check to see whether in your pagelayout.tpl, {$module_result.content} is within a cache block. This problem is not noticeable on node views since you're used to page being cached by the viewcache. {$module_result.content} should always be outside of cache blocks.

Tuesday 26 April 2011 11:19:45 am

All seems to be ok.

I had a cache block into my page layout file.

Thnx

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from