This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Developer » eZ publish 3.x on PHP 5
expandshrink

eZ publish 3.x on PHP 5

eZ publish 3.x on PHP 5

Tuesday 05 September 2006 12:57:19 pm - 60 replies

Good news for the PHP5 fanatics!

I've managed to hack eZ's source code and finish the setup wizard on Apache2/PHP5.1.2 (zend 1 compatibility mode off) on Suse Linux 10.1.

More news on this soon... happy.gif Emoticon

Tuesday 31 October 2006 8:13:11 pm

Hi,

Today I was check out from http://pubsvn.ez.no/svnparent/nextgen_php5/stable/3.8/ latest version of ez Publish port for PHP5

1. then i trying install eZPublish with shop_site.ezpkg - on the last step I got error:

[ Oct 31 2006 20:50:08 ] [127.0.0.1] eZMySQLDB:
Query error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND
ezuser_discountrule.discountrule_id = ezdiscountru' at line 5. Query: SELECT DISTINCT ezdiscountrule.id,
ezdiscountrule.name
FROM ezdiscountrule,
ezuser_discountrule
WHERE ezuser_discountrule.contentobject_id IN ( ) AND
ezuser_discountrule.discountrule_id = ezdiscountrule.id
[ Oct 31 2006 20:50:08 ] [127.0.0.1] eZDBInterface::commit TRANSID-ea384233f50889142506f67a59f29b42:
Transaction in progress failed due to DB error, transaction was rollbacked. Transaction ID is TRANSID-ea384233f50889142506f67a59f29b42.

2. Plain site was install success - but then I add translations files - I got blank page - In user siteaccess & admin siteaccess

My system is Fedora Core v5 x86_64 with Apache2/PHP v5.1.2

P.S>

I can submit file var/ezpublis_php5.csv - which contains lot of warnings & errors

Bye.

Wednesday 01 November 2006 9:43:58 am

Hi Denis

Thanks for testing!

Please send var/ezpublis_php5.csv to kristof.coomans@telenet.be. I'll try to fix it as soon as possible.

Saturday 18 November 2006 1:08:27 am

Hi Kristof

I tried your port on PHP5 and just want to report some minor problems (and hopefully the fixes as well...).
First the facts:
EZ 3.8.6
Revision 18 (that's the info from tortoiseSVN)
SVN revision:17272 (that's the info from EZ)
Gallery Site
Apache/2.0.54 (Debian GNU/Linux) PHP/5.1.5 DAV/2
no imagemagick

Here the errors:

Fatal error: Using $this when not in object context in XXXX/lib/ezimage/classes/ezimagegdhandler.php on line 668
Fatal error: eZ publish did not finish its request 

appeared when viewing the user site access the first time.
Solved by replacing $this->imageCreate with eZImageGDHandler::imageCreate in lines 668 and 684

Strict Standards: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in XXXX/lib/ezutils/classes/ezdebug.php on line 898

Same error message for /lib/ezfile/classes/ezlog.php on line 123
Appears all the time when a page is viewed the first time.
Solved by adding

php_value date.timezone Europe/Luxembourg

to my htaccess.
More about that here: http://lu.php.net/date_default_timezone_set

Apart from that it seems to work alright but I have not tried it to much yet. If I should find other problems, I'll post again.

Thanks for the doing the port, this way I can try it on my shared hosting as well.

Claudia

Saturday 18 November 2006 7:39:50 am

Hello Claudia

I'll fix it as soon as possible. It seems like I made some other mistakes in the image libraries too. Thanks for reporting!

Friday 01 December 2006 7:57:01 pm

Hello last year I wanted to test EZ, but dident have time play with the install/setup game. New try now!

Because the guy who make the php installer for OS X advices (
http://www.entropy.ch/phpbb2/view...c.php?t=2477&highlight=installer
)
not to use any software that is dependent on old PHP, your porting comes as a rescue. I started the installer and at the last page I got this errormessage: http://www.nuna.no/ez/error_lastpage.html

the installreport is here: http://www.nuna.no/ez/site_registrering.html

Friday 01 December 2006 8:24:08 pm

Hi

On Fedora 6 installation is ok.
After instalation not work i18n.

Bye.

Saturday 02 December 2006 10:20:54 am

Hi,

Kristof is calling for help:

http://ez.no/community/forum/deve...r/developers_wanted_for_php5_version

Anyone more ?

X+

Saturday 30 December 2006 3:37:05 pm

@Erland:
Thanks for giving it a try. I think those errors are not caused by the PHP5 port. There are several forum threads about similar errors with the original eZ publish.

@Denis:
We'll have a look at i18n.

@Claudia:
Didn't have the time to fix it yet, sorry. I'll warn you when it's fixed.

Tuesday 09 January 2007 4:53:18 pm

@Erland: Did you try to use the information_schema database when installing eZ? it won't work. Sorry if that's a daft question, I just saw it mentioned happy.gif Emoticon

@Claudia: the GD things should now be fixed.

@Denis: Still looking at it.

Wednesday 31 January 2007 9:33:56 am

I've merged eZ publish 3.9.0 to our PHP5 repository yesterday. Most issues were solved already, so please give it a try blunk.gif Emoticon

I'll be setting up a separate package repository for the PHP5 version the next hour, because the normal ezwebin_site package is not compatible with it.

Tuesday 27 March 2007 12:51:41 am

Warning: fopen(var/ezpublish_php5.csv) [function.fopen]: failed to open stream: Permission denied in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1930

Warning: fputcsv() expects parameter 1 to be resource, boolean given in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1943

Warning: fclose(): supplied argument is not a valid stream resource in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1944

Warning: fopen(var/ezpublish_php5.csv) [function.fopen]: failed to open stream: Permission denied in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1930

Warning: fputcsv() expects parameter 1 to be resource, boolean given in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1943

Warning: fclose(): supplied argument is not a valid stream resource in /home/a*****/public_html/ezp/lib/ezutils/classes/ezdebug.php on line 1944

this is the errors i got when i installed the 3.9 php5 that i downloaded today, the error are in the top part of the installer on the first page

Operating system Linux
Kernel version 2.6.13-15.13-smp
Machine Type i686
PHP version 5.2.1
MySQL version 4.1.21-standard
Apache version 1.3.37 (Unix)
PERL version 5.8.7

hope that is enough info to help, i think this is a good idea.
pat on the back Kristof wel done
sammie x

Wednesday 28 March 2007 8:03:03 pm

Hi Sammie

How's your sexual advice business going? blunk.gif Emoticon

I guess you just need to alter the permissions on var/ezpublish_php5.csv. The webserver needs to have write access to it. Good luck!

By the way, I've merged 3.9.1 into the port last week.

Modified on Wednesday 28 March 2007 8:04:14 pm by Kristof Coomans

Monday 09 April 2007 4:21:07 pm

Great work, Kristof

I have read all the previous posts, but I don't know where should I download your latest version (<b>eZ Publish 3.9.1 on PHP5</b> ?).
Within WebSVN, I found the following directory structure:

--original
----3.8
----<b>3.9</b>
----2007-03-21-php5
--stable
----3.8
----<b>3.9</b>
--unstable

There are two 3.9 branches. Which one should I select?

Thanks!

Modified on Monday 09 April 2007 4:30:01 pm by Jianjun Hu

Tuesday 10 April 2007 8:01:01 am

Hi Jianjun

Original/3.9 is the branch with the official eZ systems releases (PHP 4.4), stable/3.9 is the branch with the corresponding PHP5 version.

The work I've done so far was recently merged into the nextgen repository, on http://pubsvn.ez.no/nextgen/unstable/2007-03-21-php5, but I wouldn't recommend using it because there will probably be more structural changes on that one in the future. Until eZ systems releases an official PHP5 port, I'll keep the PHP 5 port in http://pubsvn.ez.no/svnparent/nextgen_php5/ up to date with new releases and I'll make sure it remains compatible with the PHP 4 version as much as possible.

Sunday 13 May 2007 10:59:29 am

Is it possible to have an archive with all files for the 3.9 stable ?

// Sorry, I have understood how to get the archive ^^.

Modified on Sunday 13 May 2007 11:01:56 am by Campesato Maxime

Thursday 12 July 2007 5:52:19 pm

PHP Fatal error: Using $this when not in object context in /home/adrian/Workspace/webroot/ezpublish/kernel/classes/ezcontentlanguage.php on line 229

replace

foreach ( $this->fetchList( $forceReloading ) as $language )

with

foreach ( eZContentLanguage::fetchList( $forceReloading ) as $language )

Friday 13 July 2007 12:17:32 pm

I'll fix that in SVN just now.

Monday 10 September 2007 2:04:03 pm

I attempted to install this version of eZ publish but ran into a problem with the database character set. I created a database using utf-8, and the default character set for my MySQL installation is utf-8. However, the eZ publish installation is stuck on:

" This page lets you modify information about the site you've chosen to install. In addition, it also lets you choose a database for the site.

Warning
The database [ezphp5] cannot be used, the setup wizard wants to create the site in [utf-8] but the database has been created using character set [iso-8859-1]. You will have to choose a database having support for [utf-8] or modify [ezphp5] ."

I cannot modify the db because it's already utf-8. And the installation will not go any further.

Ideas?

Monday 17 September 2007 9:01:56 pm

Hi Maria,

try to alter your database dafault characterset to utf8:

Alter DATABASE `database_name` /*!40100 DEFAULT CHARACTER SET utf8 */;

Regards

Thursday 20 September 2007 3:43:29 pm

I have problem editing user rights on my eZP 3.9.3 PHP5.
When I go in Administration panel into "User accounts" and click group "Editors" then I got this:
"Fatal error: eZ publish did not finish its request
The execution of eZ publish was abruptly ended, the debug output is present below."

in php_error.log I foud :
"PHP Fatal error: Call to a member function attribute() on a non-object in /u01/www/eZ/kernel/classes/ezpolicylimitation.php on line 244"

The line is:
"$functions =& $mod->attribute( 'available_functions' );"

Any help will be appreciated.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from