eZ Community » Forums » Developer » "Fatal error: eZ Publish did not...
expandshrink

"Fatal error: eZ Publish did not finish its request" when trying to regenerate extensions

"Fatal error: eZ Publish did not finish its request" when trying to regenerate extensions

Thursday 03 April 2014 1:38:20 pm - 4 replies

Hi,

We were having a timeout problem with our site, I tried to clear the cache but then got the same error (bizarrely nothing was entered into the PHP error log) and I found one possible suggestion is to regenerate the extensions, and yup... same error.

After much trial and error, increasing the memory limit (to 512MB) on the server enabled me to clear the cache, and after the cache was cleared the site worked fine too thankfully, however, I figured in the interest of making sure everything was running smoothly I'd regenerate the extensions, and now instead of taking ages before producing the error, it says:

Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended. Contact website owner with current url and what you did, and owner will be able to debug the issue further.

Pretty much instantly.

Does anyone please know how to fix this? Here are the enabled extensions by the way: http://imgur.com/LMERHXH.jpg

Thanks!

Thursday 03 April 2014 3:56:39 pm

Hi Nick! 

This usually means that eZ Publish encountered a fatal PHP error, and couldn't run. A couple of things to check: 

  • Check your PHP error log, and make sure error logging is configured in your php.ini
  • Check eZ's own error log (var/log/error.log or ezpublish_legacy/var/log/error.log depending on the version)
  • Make sure that your environment matches the requirements for the version of eZ Publish you're running. Also, on some distributions, you can have different PHP configurations for command line vs Apache - if you had to raise your memory limit, you might have to do it again for the command-line in a separate php.ini
  • One of the more common things I've seen with causing the regenerate to fail is that the kernel autoload is out of date. Try running bin/php/ezpgenerateautoloads.php -k

Thursday 03 April 2014 4:55:30 pm

Thank you very much Joe, I have checked both the PHP error log and eZ's own logs and there's nothing in there relating to this error (I cleared them both, ran the page to generate the error and neither were populated) but error logging is on, becuase other errors/warnings generated recently were in there before I cleared it.

Please pardon my ignorance, but how do I run ezpgezpgenerateautoloads.php? I've tried running it from the address bar with no luck, also the command line like so: http://i.imgur.com/viMAolV.jpg

But it didn't seem to have done anything unfortunately sad.gif Emoticon

Thanks again

Thursday 10 April 2014 10:47:14 am

Hello Nick,

I had the same problem.
The GenerateAutoload module checking in all "classes" folder in each extension the classes files to regenerate the /var/autoload/ezp_extension.php.In a case or a file is not a PHP class, eZPublish return a FatalError. sad.gif Emoticonsad.gif Emoticon

For example, if you add the PHPExcel Lib in your extension, you will have some files like "classes/PHPExcel/locale/cs/config" or "classes/PHPExcel/Shared/PDF/tcpdf.crt" which will pose a problem.

So, check in your extensions this specific files and move it in a folder named "lib".For example : "classes/lib/PHPExcel/...

Modified on Thursday 10 April 2014 10:47:41 am by Franck Chaux

Monday 19 May 2014 11:08:42 am

Can you say the version of your PHP and eZPublish ?

 

Nromally the problem with generating autoload should be somewhere in ezpublish var log or apache error log.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from