This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Developer » Help load image
expandshrink

Help load image

Help load image

Sunday 05 August 2012 5:12:08 pm - 5 replies

regards
I tried to load an image on the tag and does not work please help.

<div data-iview:image={$child.data_map.image.content[original].url|ezurl('no','full')} slice-top-fade,slice-right-fade">

Modified on Monday 06 August 2012 2:35:00 pm by Edixon Rivera

Wednesday 08 August 2012 8:58:44 am

Hi Edixon,

What's the output you are getting from the above code?  What output were you expecting?

You have a closing quote but no opening quote in the code above.

Geoff

Wednesday 08 August 2012 3:05:58 pm

The idea is to load an image in a class, I used a number of options and does not load the image.

Wednesday 08 August 2012 11:14:36 pm

What's the HTML output you are getting from the above code?  What HTML output are you expecting? I'd suggest trying to output the image URL without the HTML code around it first.

Trying using dot notation for the image alias, ie 

$child.data_map.image.content.original.url

If this doesn't resolve the issue, please provide more code or information so that others can help you - it's hard to debug with limited information.

Cheers,

Geoff

Thursday 09 August 2012 1:21:48 am

Ok, thanks for the reply.

Monday 02 September 2013 10:10:09 am

Hi ,this is my method to load image in c#.you can have a look:

<span class="kwrd">public</span> <span class="kwrd">static</span> REImage OpenImageFile(<span class="kwrd">string</span> filePath);
<span class="kwrd">public</span> <span class="kwrd">static</span> REImage OpenImageFile(<span class="kwrd">string</span> filePath, BaseDecoder dec);
expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from