This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Developer » including template and memory issue
expandshrink

including template and memory issue

including template and memory issue

Wednesday 02 February 2011 2:05:34 pm - 3 replies

Hello there,

I used to have a PHP memory issue (Allowed memory size in a cache file) on an include operator:

{include uri='design:subdirectory/included_template.tpl'}

, and I did not know where the error came from.

Deleting the include solved the problem, more, I changed to (removing the subdirectory):

{include uri='design:included_template.tpl'}

And it solved my PHP memory error. Did someone got this error? Is it a eZ Publish "bug"?

Thanks!

Wednesday 02 February 2011 9:50:15 pm

What is the memory limit you have in php.ini? eZP likes it quite high...

ps: sorry, did not look at the sig of the op. Maybe you got a loop in the included tpl code, or an unbounded fetch?

Modified on Wednesday 02 February 2011 9:51:40 pm by Gaetano Giunta

Thursday 03 February 2011 10:11:54 am

Hi Gaetano,

I reproduced this "bug" on my local, memory limit is 128MO (high enough), no fetch, no loop, so weird...

I corrected it by removing the subdirectory, so technically corrected, but weird...

Thanks!

Tuesday 15 November 2011 5:34:11 pm

If the subdirectory (or lack thereof) made the difference, then it almost sounds like the problem could be related to the way eZ caches includes directories.

I'd be interested to know whether any subdirectory would cause this problem, or if it had something to do with this specific subdirectory's name.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from