eZ Community » Forums » Developer » Incorrect APP1 Exif Identifier.
expandshrink

Incorrect APP1 Exif Identifier.

Incorrect APP1 Exif Identifier.

Sunday 28 November 2010 9:04:21 am - 6 replies

#015547: Exif-related issues

http://issues.ez.no/IssueView.php?Id=15547

http://issues.ez.no/IssueView.php...rojectId=3&Anchor=Attachment6522

Still this issue has been seen as unresolved . Anyone knows fix fo this.

For some edited images, exif data is not taken .

Incorrect APP1 Exif Identifier Code in /var/www/html/ez/lib/ezimage/classes/ezexifimageanalyzer.php

Is this is can very badly affect my site. Can I discard it .

Please do a help

Regards

Romeo

Sunday 28 November 2010 12:32:09 pm

Hello,

Try to replace :

if ( function_exists( 'exif_read_data' ) ) (line 62) by something like:

if ( function_exists( 'exif_read_data' ) && strpos ($printInfo['APP1'], 'Exif') === 0 )

I haven't tried it but it should work.

Daisy

Sunday 28 November 2010 1:03:20 pm

Thankyou Daisy. it worked

Romeo

Modified on Sunday 28 November 2010 1:12:41 pm by Romeo Antony

Sunday 28 November 2010 1:06:15 pm

Does it work ?

Modified on Sunday 28 November 2010 1:07:29 pm by Daisy Radix Leroy

Sunday 28 November 2010 1:13:09 pm

Daisy it worked.

Thanks a lot

Monday 21 January 2013 6:47:29 pm

Hey Daisy,

Do you think there might be a patch without modifying the kernel file?

Thanks,

JL

Monday 21 January 2013 8:26:52 pm

Hello JL, : 

I haven't tried but I think you can do something like this http://www.pixla-web.com/content/faire-un-override-dune-classe-du-kernel. 

You should add your new classe in lib folder instead of kernel folder. 

Modified on Monday 21 January 2013 9:32:43 pm by Daisy Radix Leroy

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from