eZ Community » Forums » Developer » ldap configuration
expandshrink

ldap configuration

ldap configuration

Thursday 25 July 2013 5:03:06 pm - 1 reply

Hello,

I have a website which uses an sso connection. When a user is logging, I try to find him in the ldap serveur and create users group if necessary.

I've upgraded the website from 4.0.1 to community project 2012.8

Do you know if I have something to change in my settings ?

Here is my ldap.ini.append.php

 

[LDAPSettings]
 
LDAPVersion=3
LDAPEnabled=true
 
LDAPServer=...
LDAPPort=389
# Specifies the base DN for the directory.
LDAPBaseDn=...
LDAPBindUser=...
LDAPBindPassword=...
# Could be sub, one, base.
LDAPSearchScope=sub
 
LDAPEqualSign=--
 
LDAPSearchFilters[]
# LDAP attribute for login. Normally, uid
LDAPLoginAttribute=samaccountname
# Could be id or name
LDAPUserGroupType=id
 
# depends on LDAPUserGroupType.
LDAPUserGroup=84
 
LDAPDebugTrace=enabled
 
LDAPGroupMappingType=UseTreePosition
LDAPGroupBaseDN=
 
LDAPGroupClass=group
LDAPGroupNameAttribute=memberOf
LDAPGroupMemberAttribute=member
 
LDAPGroupDescriptionAttribute=cn
LDAPUserGroupMap[]
 
LDAPGroupMappingType=GetGroupsTree
LDAPGroupBaseDN=...
LDAPGroupClass=group
LDAPGroupNameAttribute=cn
LDAPGroupMemberAttribute=member
 
# LDAP attribute type for user group. Could be name or id
LDAPUserGroupAttributeType=name
# LDAP attribute for user group. For example, employeetype. If specified, LDAP users
# will be saved under the same group as in LDAP server.
LDAPUserGroupAttribute=
 
# LDAP attribute for First name. Normally, givenname
LDAPFirstNameAttribute=givenname
# LDAP attribute for Last name. Normally, sn
LDAPLastNameAttribute=sn
LDAPEmailAttribute=mail
Utf8Encoding=false
KeepGroupAssignment=disabled

Friday 26 July 2013 3:54:45 pm

Hello,

In addition to my problem, I had to use the ezldapuser of 4.0.1 version otherwise it does not work. :s

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from