eZ Community » Forums » Developer » Problem image not show on front
expandshrink

Problem image not show on front

Problem image not show on front

Friday 31 October 2014 2:23:04 pm - 8 replies

Hi,
I have a problem with image in front office.
I can see image in Back office but in front office I just <p></p>.
Anonymous got right on content/read/Media
It's of rich text type, and the installation of eZ is 4.7.
Can you help me please ?
Thank a lot.

Friday 31 October 2014 3:12:07 pm

Hello Simonin,

I think we will need you to share more information in order to be able to help you.

Can you share all your Anonymous role rules?

Have you enabled debug output and cleared all caches to see what exact errors you are getting on the page in question? You can use the DebugByIP feature to only expose debug output to your internet connection and not everyone (if this is a production website).

It strongly sounds like your role policy rules are not quite enough to provide access to the image content.

Cheers,
Heath 

Friday 31 October 2014 3:47:36 pm

Hi thank for your answer.
I clear cache and I no message in apache and ez publish debug sad.gif Emoticon
The rules are :
- Content | read | Section (Standard, Media)
- Content | view_embed | no limitations
- page | all function | no limitations
- user | login | no limitations
- content | tipafriend | no limitations
- newsletter | archive | no limitations
When I disabled content/read/Media, I have the message :
"You do not have permission to view this object" and when I enabled this rule the message disapear, and I just <p></p>

Friday 31 October 2014 6:17:35 pm

Hello Simonin,

Based on what you just shared regarding role policies and debug messages (is that error on the front page?) I think that your having some other problem not role policy related.

What does your apache / ezpublish error log say when you load the page (with all caches cleared)? There may be helpful log entries to learn more from if you would check.

Also have you manually tried to copy the url to the image from the admin and tried to load the uri on the user siteaccess? I would try to do that as well.

I hope this helps!

Cheers,
Heath 

Monday 03 November 2014 12:03:13 pm

Hi!

How do you display this image? {attribute_view_gui}?
And in that case, how does your image.ini setting look for the siteaccess?

This looks like the typical behaviour you get when trying to view an image alias that does not exist..

Modified on Monday 03 November 2014 5:38:19 pm by Håvard Bergersen

Tuesday 04 November 2014 7:12:51 am

Hello Håvard,

You just asked a very key question; Thank you!

If Simonin was using attribute_view_gui the image alias variation image file would be created automatically on demand with no other action or code required.

He must be trying to hard code the image usage manually.

Lets hope Simonin replies soon with more information on exactly how his template is coded.

I hope this helps!

Cheers,
Heath 

Tuesday 04 November 2014 12:25:43 pm

That's true happy.gif Emoticon Unless he sends in a image variation that does not exist. E.g.:

 {attribute_view_gui attribute=$node.data_map.image image_class='some_class'}

In witch case the 'some_class' image alias has to be defined.

Tuesday 04 November 2014 1:14:10 pm

Thank for your answer !

@Heath :

Also have you manually tried to copy the url to the image from the admin and tried to load the uri on the user siteaccess? I would try to do that as well.

I can see the picture.

And I use attribute_view_gui on richtext not directly image.

Wednesday 05 November 2014 12:04:09 am

Hello Simonin,

Have you defined your image alias in a specific siteaccess or global (override) settings? This very well could be your problem.

Please share your image.ini.append.php configuration for your global override and siteaccess settings!

What is the name of the image alias being used in your template code?

Can you share the uri to the image (this might help us debug your problem)?

Have you verified the 'convert' binary is installed on the server?

What is the path to the 'convert' binary?

Do you have an siteaccess or override settings specific configuration for the 'convert' binary?

settings/override/image.ini.append.php

[ImageMagick]
IsEnabled=true
ExecutablePath=/usr/bin
Executable=convert

I hope this helps!

Cheers,
Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from