eZ Community » Forums » Developer » Problem to access "Content" with webdav
expandshrink

Problem to access "Content" with webdav

Problem to access "Content" with webdav

Thursday 10 May 2007 3:10:58 pm - 1 reply

Hi everybody,

I use a eZ Publish 3.8.3 instance in cluster mode and I have a problem to access to the content tree of my site access with webdav clients ( Konqueror 3.5, netDrive or Internet Explorer 6, 7). I have no problem to browse, download or upload files in the "Media" folder but I can't see data in the "Content" folder -> "Content does not exist" message in Konqueror (there are no error message in the webdav log).

Process of configuration:
1) editing settings/override/webdav.ini.append.php
-> create file and add parameters:
[GeneralSettings]
EnableWebDAV=true
Logging=enabled

2) Host configuration:

<Virtualhost xxx.xxx.xxx.xxx>
    ServerName webdav.xxx.com
    ServerAlias webdav.xxx.com
    <Directory /ezpublishDirectory>
        Options FollowSymLinks Indexes ExecCGI
        AllowOverride None
    </Directory>
    DocumentRoot /ezpublishDirectory
    RewriteEngine On
    RewriteRule . /webdav.php
</VirtualHost>

3) Clear all caches

4) Use Konqueror with webdav://webdav.xxx.com, netDrive with http://webdav.xxx.com and Internet Explorer with http://webdav.xxx.com/#

I see others users have the same problem in a older post of the forum (http://ez.no/community/forum/inst.../webdav_can_t_navigate_into_content) but the bug of incorrect characters has been solved in the 3.8 branch normaly.

I see in another post (http://ez.no/community/forum/inst...figuration/v3_8_3_clustering_webdav) and in a comment of the documentation (http://ez.no/doc/ez_publish/technical_manual/3_8/features/webdav) than webdav don't support cluster mode. My webdav configuration have worked fine when my site wasn't in cluster mode, but actualy I have no problem to browse or upload content in the "Media" folder with a cluster configuration. I don't use webdav since a lot of time and I can't make the link with the switch to the cluster configuration and the access problem of "Content" folder in webdav.
Somebody have any information about limitation of webdav support in cluster mode???

Thursday 10 May 2007 8:06:36 pm

I found the solution of my problem.
Curiously, in ezurlalias table, the main node (node_id: 2) wasn't have a destination_url. (o_O)
If this was not a problem for browsing in the back office, webdav can't accessing to the destination of "Content". I don't know why this problem arrived suddenly and how my main node_id lost the destination_url, but it was the origin of my problem.

PS: In fact, I confirm we can use webdav with eZ Publish in cluster mode.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from