eZ Community » Forums » Developer » Problems with caching...
expandshrink

Problems with caching...

Problems with caching...

Thursday 14 September 2006 10:46:33 am - 11 replies

Hi!

I'm trying to implement a new functionality in our system, but have some problems with caching.

In a folder, I've added a new xml-field. This field is listing content in a right menu.
Everything is working great, but I've created a custom tag with it's own template which fetch the latest 3 articles from another node. This custom tag is inserted in this xml-field and the content is displayed in the right menu, but when I create a new article in the specific node where the fetch is getting the data, this page with the right menu is not updated with the new article.

I've tried to add both:
{set-block scope=root variable=cache_ttl}0{/set-block} in this custom tag template which is inserted in the xml-field on a page, but it don't work. I have also tried:
{cache-block expiry=60} in this custom tag template, but it don't work either.

BUT, when I edit the page which contains this xml-field which also got the custom tag inside, and republish, the latest published article are displayed in the fetch. This means, that I have to republish the page to clear the cache for this page everytime I want a new published article to get displayed, which is not so very effective. I can clear the cache for the page everytime a user is visiting this page(in the template), but this will make the system very slow (without caching for the specific page).

Does anyone have a solution on how I can fix this problem?

K259

Modified on Thursday 14 September 2006 11:57:21 am by K259

Thursday 14 September 2006 1:13:27 pm

Hi,

If you know what node(s) is going to contain the block to refresh, you can use the smartcache settings.

X+

Thursday 14 September 2006 1:19:02 pm

Hi!

Thanks for the tip,but smartcache is already enabled :/

Thursday 14 September 2006 1:24:25 pm

And I also have the sitedesigns set in AvailableSiteDesignList in content.ini..

Modified on Thursday 14 September 2006 1:28:29 pm by K259

Thursday 14 September 2006 2:05:43 pm

hmm..this is not ez :p

Modified on Friday 15 September 2006 10:46:32 am by K259

Friday 15 September 2006 10:51:44 am

Hi

Have you configured something specific in the viewcache.ini for your case ?

X+

Friday 15 September 2006 11:04:16 am

No, not for this case.

Friday 15 September 2006 11:20:04 am

It seems to me that the problem is that the Folder object that contains this new xml field (where you insert your custom tag) is cached. So when you create a new article in the node where fetch is getting the data, the cache for that node is cleared but cache for the node containing this new xml field with custom tag related with your custom template is not cleared. The result is that yout custom template in which you fetch the data is not executed.

This could maybe be due to ViewCaching being enabled. Try one of this:

1. put {set-block scope=root variable=cache_ttl}0{/set-block} in the template used for view of the node containing this new xml field
...and clear the cache

2. disable ViewCaching
...and clear the cache

3. disable all the cache in the site
...and clear the cache

Try these suggestions one by one and see which one gives you the wanted result. So then maybe you'll be able to tell where exactly is the problem.

Friday 15 September 2006 11:41:31 am

Marko, this is exactly the problem. When I add {set-block scope=root variable=cache_ttl}0{/set-block} to the main page which got this custom tag template included in its xmlfield, the fetch is ok, but this is a main page, and it needs to be cached..or else the whole system will crash due to overload with processing.

I then need to fix something so that only the custom tag template inside of this xmlfield is cleared(the cache) after a new object is published, so that not the cache for the whole node is cleared.

Friday 15 September 2006 12:02:27 pm

I guess there's no solution to this in ez publish today, because not so many have come to this topic with the use of custom tags sad.gif Emoticon

Saturday 16 September 2006 8:12:50 am

Hi,

If you know where your custom tag is going to be used and what objects it can include, you can add that in the the smart cache feature.

I usualy have to create relations between one of the published parent's node and the node I want to clear and use some clear override.

That's not that easy to put in place, but I've been using it without problems in most cases.

X+

Monday 18 September 2006 10:42:29 am

Xavier..do you have a clue what settings I have to use in the viewcache.ini file?

# clear_object_caches_only
# clear_object_and_parent_nodes_caches
# clear_object_and_relating_objects_caches
# clear_parent_nodes_caches_only
# clear_parent_nodes_and_relating_caches
# clear_relating_caches_only
# clear_all_caches
#ClearCacheMethod=<method_string>

I want to clear the cache for the customtag inside of the xml field of an object of node x..

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from