eZ Community » Forums » Developer » RSSIMPORT RSS version 1.0 VS 2.0
expandshrink

RSSIMPORT RSS version 1.0 VS 2.0

RSSIMPORT RSS version 1.0 VS 2.0

Tuesday 13 January 2015 11:57:22 am - 4 replies

Hi everyone,

I need to import RSS feed from a rss version 1.0 but it doesnt work , when i try rss version2.0 i have no problem. like YAHOO or BBC

Do you have any idea?

Tuesday 13 January 2015 12:19:34 pm

Hello pa,

I know from a lot of hands on experience that if the rss feed content version (markup of v1.0 vs 2.0) does not match the version you specify in the admin the rss import cronjob will -not- import the content and will fail to do anything outputing a message that says something like 'Invalid RSS version missmatch. Please reconfigure import'.

I would recommend you double check the actual markup of the rss feed content of your feed url. I suspect you think you are working with an rss 1.0 feed when you are actually dealing with a rss 2.0 feed.

In any case it should not hurt anything to configure the import to use rss 2.0 and ignore this problem as a non-issue since as you say importing as a rss 2.0 feed works without any problems. 

I hope this helps! 

Cheers,
Heath

Modified on Tuesday 13 January 2015 12:21:04 pm by // Heath

Tuesday 13 January 2015 2:38:30 pm

thanks for your answer Heath,

 

actualy when in admin interface when i go to RSS / import ,i use URL source -> update, i have this line: 

Version RSS:1.0

 

Also in view-source of my RSS i have :

    xmlns="http://purl.org/rss/1.0/"

    xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"

    xmlns:slash="http://purl.org/rss/1.0/modules/slash/"

    xmlns:dc="http://purl.org/dc/elements/1.1/">

 

 

Then when i run cronjob in shell i have :

 

Using siteaccess  for cronjob

Running cronjob part 'rssimport'

Running cronjobs/rssimport.php at: 13/01/2015 13:25

RSSImport Beewiki: Starting.

RSSImport Beewiki: End.0 objects added

Completing cronjobs/rssimport.php at: 13/01/2015 13:25

Elapsed time: 00:00:00

No error and nothing happen! do you still think i should configure the import to use rss 2.0 and if yes how can i do this?

thanks a lot

Tuesday 13 January 2015 8:05:59 pm

Hello pa,

Remember that once you import a feeds content successfully, even just once, you must remove the content from ezpublish using the content admin siteaccess to be able to re-import this content, otherwise until there is new feed content to import nothing new will be imported. Note: Content won't reimport if you use the trash feature so just remove the content don't put it in the trash.

Also the rss text you shared is not enough or at least does not indicate to me that it's rss v1.0. Could you perhaps share a more complete part of the feed content? In any case you don't need to share more of the feed since ezpublish auto detects the feed version automatically.

Please remember that ezpublish by default does not import atom feed content (To my knowledge) there are separate / different extensions for that use case. Please make sure your not trying to import an atom feed.

Sorry. I made a mistake in my previous message (I got confused for a second there). The rss 2.0 import feed choice is made -for you- automatically when you setup the feed for import in the admin. You don't actually have control over this aspect. Never mind. Edit: I confused in my mind import with export which does have this drop down option. 

I hope this helps!

Cheers,
Heath 

Friday 13 February 2015 10:28:49 am

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from