This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Developer » SJSD WYSIWYG editor based on...
expandshrink

SJSD WYSIWYG editor based on FCKEditor for ezxmltext

SJSD WYSIWYG editor based on FCKEditor for ezxmltext

Wednesday 12 April 2006 5:56:35 pm - 236 replies

This thread is for the project SJSD (contribute: http://ez.no/community/contribs/a...d_real_fckeditor_xmltext_integration )

Please ask your questions in this thread rather in the contribution section.
If you do not expect replys, please add comment in the contribute section happy.gif Emoticon

<b>HOWTO DEBUG this extension</b>
As the nature of this project, there are two main sources of bugs: javascript running in client side and the server side php scripts

DEBUG Javascript:
*Firefox (at least 1.5) comes with a javascript console, and it can give precise information about where and why some commands in the javascripts fail.

*IE: without Microsoft script editor/debugger, the error message is basically useless. One of them is recommanded (Microsoft script debugger is free for downloading).

DEBUG PHP:
When using the editor, there are two buttons at the end of the toolbar: the first one will show the current html source of the editor. The second one is more interesting: onloading, it will communicate with ez publish server to get the converted xml from the current html source. There will be a button "Output" after the xml is displayed, it will ask the server to convert the xml back to html, and show it in the window. After this, a ok button will appear, which can be used to set the new generated html back to the sjsd editor.

<b>BEFORE REPORT BUGS</b>
Please check bugs and "feature requests" sections in our homepage: http://sf.net/projects/scim
if it is not there, you can file one (the prefered method), or state it here

Modified on Tuesday 11 January 2011 9:59:40 am by Nicolas Pastorino

Tuesday 09 May 2006 4:05:47 pm

ok, fixed in r128

to Jeroen Sangers:
what's the content of the error message? Do you use a user in the administrator group? or a normal user? if latter, please grant the access to module sjsd

Tuesday 09 May 2006 11:58:08 pm

I tried to acces svn for sjsd:

http://svn.sourceforge.net/viewcvs.cgi/sjsd/

but I get "503 Service Unavailable" error. Is there any other way that I can download the newest version of sjsd (preferably through a web interface)?

When will a new version be available for download on sourceforge?

Wednesday 10 May 2006 12:18:12 am

to Marko Zmak:
the address you tried is for cvs in sf

see here for how to check out svn:
http://sourceforge.net/svn/?group_id=164632

Wednesday 10 May 2006 7:59:52 am

I followed the link you suggested and on that page I clicked on "Browse Subversion Repository" link which got me to the page with error I described.

On the server where I want to use sjsd I don't have a svn client (and can't install it) so I would like to find latest svn version of sjsd via a web interface. How can I do it?

Or should I wait for the new release to come as a download on SF?

Wednesday 10 May 2006 10:24:13 am

The message was exectly as I wrote in my message:

"Returned value is not in valid JSON format: Error: Content is not found or function is not reconganized!"

It only appears after clicking on the paperclip button. Other functions appear to work fine, though I haven't tried them all. I work with a user from the administrator group.

Wednesday 10 May 2006 12:18:01 pm

O.K. I managed to download the newest version. The problem with &Scaron is solved now. But now there's another problem. The simbols for quotes usually used in MS Word (the one that are similar to this << and this >>blunk.gif Emoticon is not displayed correctly in my site. In the editor the simbola are displayed OK, but in the site it are displayed as &raquo; &laquo;. Also the long line (a little bit longer than this one: -) is displayed as &#8211;

When I look in the data in the database I see that the quotes are saved as:

&amp;raquo;
&amp;laquo;

And I supose that's why they are not displayed correctly. I thing that they should be stored in DB as "&raquo;" and ";laquo;", and then they will probably be displayed OK.

I don't know if this is sjsd bug or FCKEditor's bug. Could you check it?

If you need any further details about this problem and my site config, feel free to ask.

Wednesday 10 May 2006 12:42:20 pm

Hi Marko,

How did you manage to download the latest version ?
Because when I go to http://sourceforge.net/svn/?group_id=164632 and clic to "Browse Subversion Repository" I get the same error message you described ?

Pascal

Wednesday 10 May 2006 1:04:47 pm

Hi,
You should use a svn client to download the version. See here http://sourceforge.net/svn/?group_id=164632

It's not as scary as it might look, and the benefit is so high for the updates that its really worthwhile.

You can also try downloading from the main page:

http://sourceforge.net/projects/sjsd

X+

Wednesday 10 May 2006 1:06:06 pm

It might also be a sourceforge issue with their svn server.

Paul

Wednesday 10 May 2006 1:37:40 pm

Hi Xavier,

I'm a beginners not familiar with subversion.
I installed kdesvn but when I try to checkout a repository using http://svn.sourceforge.net/sjsd I get this error message:

PROPFIND request failed on '/sjsd'
PROPFIND of '/sjsd': 302 Found (http://svn.sourceforge.net)

Is it due to a sourceforge issue with their svn server, as told Paul ?

Pascal

Wednesday 10 May 2006 1:45:58 pm

The url to use is:

https://svn.sourceforge.net/svnroot/sjsd

If you look at the subversion page it gives you a handly link to use:

http://sourceforge.net/svn/?group_id=164632

paul

Wednesday 10 May 2006 1:46:47 pm

Hi,

Don't know about doing a check out, but an update from the shell worked fine a couple of minutes ago.

Updated to revision 128.

Wednesday 10 May 2006 1:55:50 pm

Merci Xavier,

I do it too with

svn co https://svn.sourceforge.net/svnroot/sjsd sjsd

and it works fine.

Pascal

Wednesday 10 May 2006 2:24:24 pm

De rien.

Welcome in the subversion world blunk.gif Emoticon

I'd suggest to do the same with on the the stable branch for ez from pubsvn.

On pub svn, you're going to grab quite a few extensions too, and we are usually better at keeping the latest version there than on the countrib pages.

X+

Wednesday 10 May 2006 2:39:27 pm

Now SJSD is working on my 3.7.5, I tested the "lists".
In "edit" mode, I type this:

   1.  A
   2. B
         1. AA
         2. BB
               1. CCC
               2. DDD
   3. C
   4. D

Once I save my document, I get this in the frontend:

   1. A
   2. B
   3. C
   4. D

Is it a bug, a limitation ?
I did a search about that on this topic and found nothing, neither on the bug page http://sourceforge.net/tracker/?a...&group_id=164632&func=browse

Pascal

Wednesday 10 May 2006 4:47:15 pm

to pascal France:
it is working here. Are you sure you clear all your cache (server/client)?

to Marko Zmak:
I can not reproduce the issue, it is displayed correctly in the webpage I tried. I recommand clearing your cache (client)

to Jeroen Sangers:
what the url it trys to request? (you can find out if you have firebug, a firefox extension installed, see the post in this thread before)

BTW: I use eZ 3.8 stable branch in svn with php 4.4.2
if you guys use eZ 3.7.x, I'd suggest upgrading to 3.8

Modified on Wednesday 10 May 2006 4:52:36 pm by liu spider

Wednesday 10 May 2006 5:45:39 pm

Hi Liu,

Even if I erase both var/cache/ directory and var/plain/ it does not work.

I use a from scratch installation of a 3.7.5 version for tests.

Regards

Pascal

Wednesday 10 May 2006 5:51:09 pm

support for ez 3.7 in SJSD is not officialy supported (unless someone volunteer to do the work necessary to maintain the compatibility), so please use eZ 3.8 instead

Wednesday 10 May 2006 6:09:46 pm

I installed the FireBug extension, and configured it to show XMLHttpRequests. When loading the edit screen, the following error appears in the FireBug console:

this.DOMDocument has no properties   view-source:http://example.com/extension/sjsd/FCKeditor/editor/js/fckeditorcode_gecko_2.js (line 22)

When I click on the Paperclip icon to add an image, I see:

GET http://example.com/index.php?/sjsd/xmlhttp/GetObjectPropertyObjectList
GET http://example.com/index.php?/sjsd/xmlhttp/GetRelationlist?oid=1&ov=31
this.replace is not a function   jobparsing.js (line 3)

Wednesday 10 May 2006 6:38:07 pm

I think your fckeditor has some issues. what's the version? try to install a new 2.2

and which browser do you use?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from