eZ Community » Forums » Developer » url_alias don't use "Generated Aliases"
expandshrink

url_alias don't use "Generated Aliases"

url_alias don't use "Generated Aliases"

Tuesday 18 December 2012 4:17:23 pm - 2 replies

I have a site with with two siteaccess, eng and ita: http://www.maskins.com

If i go to an internal node in eng siteaccess i see nice url 
http://www.maskins.com/eng/Products/Mobile-phones/Samsung/Galaxy-S-III

but if i see the same node in ita siteaccess the url is this
http://www.maskins.com/content/view/full/6606

If I use nice url in ita siteaccess
http://www.maskins.com/ita/Products/Mobile-phones/Samsung/Galaxy-S-III
i can see the page.

In backend, in Advanced -> Manage Url Aliases i have nice url form ita siteaccess, but node.url_alias in ita siteaccess show always the system url.
I have truncate many time urlalias_ml table and run updateniceurl.php script, but this task have no effect.

Someone can help me?

Thank you.

Tuesday 18 December 2012 6:41:44 pm

Can you double check your italian siteaccess configuration to make sure it includes both italian and english languages for content?

Also, are the products translated?

Tuesday 18 December 2012 6:57:43 pm

Hi Gaetano,
thank you for answer.

Yes products are translated.

This is ita siteaccess settings:

[SiteAccessSettings]
RelatedSiteAccessList[]
RelatedSiteAccessList[]=ita
RelatedSiteAccessList[]=eng
RelatedSiteAccessList[]=backend
 
[RegionalSettings]
Locale=ita-IT
ContentObjectLocale=ita-IT
ShowUntranslatedObjects=disabled
SiteLanguageList[]
SiteLanguageList[]=ita-IT
SiteLanguageList[]=eng-GB
TextTranslation=enabled
expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from