This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Developer » XML block custom class
expandshrink

XML block custom class

XML block custom class

Wednesday 07 December 2011 9:03:16 pm - 3 replies

Hi,

I've got problem with online editor custom class.

I'm adding new class in content.ini.append.php like

[link]
AvailableViewModes[]
AvailableClasses[]
AvailableClasses[]=fancybox_descr

Then I create link in node wysiwyg editor. After publishing link is visible in the editor but not on the website.

I see only <p> </p>

I'm using ez 4.3

Friday 09 December 2011 8:16:03 am

Hello Margarett,

 

No worries about asking this question, it is why we are here, to help happy.gif Emoticon

Though this particular question is asked fairly often,

 

Also this article / blog (from a normally / mostly french speaking blog from a really smart eZ Publish developer) about how to do exactly what your trying to do with each step visually demonstrated with clear examples, I really like this post, I think it's what your looking to do with eZ Publish. Fortunately this article is in english though the comments are mostly in french (tip: use google translate / google chrome to easily translate the page to read the comments)

http://pwet.fr/blog/creating_a_link_to_download_a_file_with_online_editor_in_ez_publish

 

Moving on my first questions to you would be the following

  1. Please share the path (from the base ezpublish root folder) of where in the filesystem you stored your custom content.ini.append.php file (This often matters very much where you place it and the exact contents of the setting file). Note: In your example content of ini settings you shared looks just fine to me (at a glance).

See I think you may have placed your settings override file in a location which is read only by one siteaccess, which would prolly explain why the content displayed to the user omits it.

Also it seems strange that the link itself is omitted in the user siteaccess display (even if your settings file was not in a global location like settings/override dir).

  1. Can you enable all template debug, debug output, used templates list and reload to see if you can find out which template is supposed to be used in this instance :\ 

Update: Seems the base template path you want to override is, 'content/datatype/view/ezxmltags/link.tpl', here is the default template file used normally), https://github.com/ezsystems/ezpublish/blob/master/design/standard/templates/content/datatype/view/ezxmltags/link.tpl

 

I would validate that this file exists, is readable by the web server user/group, and that you can confirm it is listed either in used templates list (clear cache each time to see full list as caches limit what is shown here) -and- template debug (dirty to use at times but fairly clear when reading source code with this option to tell which file html comes from by reading the outputted sourced and reviewing the template files responsible (possible template code errors/ invalid template code?).

Also review module debug on the page for any related errors which might have occurred during processing/display.

 

I hope this helps ...

 

Cheers,

Heath

Modified on Friday 09 December 2011 8:27:44 am by // Heath

Sunday 11 December 2011 10:19:04 pm

 

Hi,

thank you very much for help.

And what I've got after debug is :

Warning: XML output handler Dec 11 2011 22:10:13
Using tag 'link' with class 'fancybox_descr' is not allowed.

File content/datatype/view/ezxmltags/link.tpl exist and is in used

File content.ini.append.php is located in the user siteaccess

/site_name/settings/siteaccess/eng

 

I will try some solutions from links above and see if it works.

 

And Voila! When I set class as global it works. Strange.

Best regards

M.

Modified on Sunday 11 December 2011 10:29:43 pm by Margarett W

Monday 12 December 2011 12:24:52 am

Hello Margarett,

 

Congratulations! I'm please you reached your goal successfully.

I'm very happy to help you.

Thank you for logging back into share.ez.no forums and
clicking the forum question resolved icon to indicate this
forum thread is now solved. This really helps others in the future.

 

Thank you

 

Cheers,

Heath

Modified on Monday 12 December 2011 12:26:00 am by // Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from