eZ Community » Forums » Developer » YUI3_config not defined
expandshrink

YUI3_config not defined

YUI3_config not defined

Wednesday 20 January 2010 12:15:32 pm - 2 replies

heya, I get this style error in IE...

I am using ez4.2 with ezwebin, tried to override the ezjscore folder with ezjscore-1.0.1-2 and tried to use

{ezscript_require( 'ezjsc::yui3' )}
<script type="text/javascript">
{literal}
YUI( YUI3_config ).use('node', 'io-ez', function( Y )
{
 Y.on( "contentready", function( e )
 {
 // Parameters can be sent as post data ('arg1=hi!') or as 
 // call parameter (eg: "ezjscdemo::search::hello" )
 // Use post for string values to not end up reaching url path limit..
 Y.io.ez( 'ezjscdemo::search', {
 data: 'arg1=hi!',
 on: {success: function( id,r )
 { 
 if ( r.responseJSON.error_text )
 Y.get( '#hello-world-id' ).setContent(
 r.responseJSON.error_text
 );
 else
 Y.get( '#hello-world-id' ).setContent(
 r.responseJSON.content
 );
 }
 }
 });
 }, '#hello-world-id' );
});
{/literal}
</script>

without my scipts but without success, YUI( YUI3_config ) produced always this error in IE... thanks for help!

------------------------------

if I use this, I get "object expected"

<script type="text/javascript">
{literal}
var YUILoader = new YAHOO.util.YUILoader({
loadOptional: true,
combine: true
});
{/literal}
</script>
<script type="text/javascript" src={"lib/yui/3.0/build/yui/yui-min.js"|ezdesign}></script>
<script type="text/javascript">
{literal}
var YUI3_config = { modules: {} };
{/literal}
</script>

Modified on Wednesday 20 January 2010 12:43:41 pm by Mischa Markus

Thursday 28 January 2010 2:08:54 pm

Check this issue:

http://issues.ez.no/IssueView.php?Id=15729

It solved the problem for me. blunk.gif Emoticon

Wednesday 03 February 2010 4:06:39 pm

yeah, if ( window.YUI !== undefined ) YUI( YUI3_config ) do it...

so simple... thanks =)

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from