This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Discussions » Discover and Using CMIS with eZPublish.
expandshrink

Thursday 10 November 2011 10:50:15 am - 4 replies

» Read full blog post

Introduction

CMIS (Content Management Interoperability Services) is a specification for improving interoperability between Enterprise Content Management (ECM) systems. 

Thursday 10 November 2011 11:13:04 am

Hello,

I've seen this extensions for a while but never tested them. Do you have a feedback on this ? Did you use them on a running project ? 

CMIS Server is written as beta, don't know why ...

Thursday 10 November 2011 11:21:11 am

Hello,

I've seen this extensions for a while but never tested them. Do you have a feedback on this ? Did you use them on a running project ? 

CMIS Server is written as beta, don't know why ...

Hi,

Not exactly running it on a "real" project. Just upgrade it and using it on a demo project. It works correctly. A test with Alfresco Cmis repo is a bit long to load all data. Maybe improvements needs to be added to cmis client... You re free to participate big-smile.gif Emoticon

Status & version of nxc_cmis_* need to be changed 

Saturday 26 November 2011 2:11:30 pm

Got it up and running with a local nuxeo DAM install. It connects to nuxeo and i can browse the nuxeo repo via cmis_client tab (/cmis_client/browser). But no matter what I do, nuxeo does not show up in the ezoe browse tab, as discribed here (imported the provided ezpkg, added policies to Anonymous user to read cmis_object and cmis_client module with no limitations in /role/list).

What am I missing?

Second question: is there a way to make files from the DAM show up within media library or all other "browse" dialogues, not just in the ezoe modal window? I it possible to access the DAM repos and files just as if they were within eZ, including DAM tags and taxonomy?

Monday 05 December 2011 12:08:04 pm

Got it up and running with a local nuxeo DAM install. It connects to nuxeo and i can browse the nuxeo repo via cmis_client tab (/cmis_client/browser). But no matter what I do, nuxeo does not show up in the ezoe browse tab, as discribed here (imported the provided ezpkg, added policies to Anonymous user to read cmis_object and cmis_client module with no limitations in /role/list).

What am I missing?

Second question: is there a way to make files from the DAM show up within media library or all other "browse" dialogues, not just in the ezoe modal window? I it possible to access the DAM repos and files just as if they were within eZ, including DAM tags and taxonomy?

Hi Jens,

About the first point its really strange. I ve test on ezpublish cmis server (nxc_cmis_server) and alfresco. Not sure, but maybe your nuxeo installation have a missed configuration ? Check on ez : cmis_client/info check if Vendor name is not empty. This is needed to display link on eZOE tab

Second part. Not really sure is a great idea, because nxc_client connect everytime you browse repository. Best way for now is to use Cmis client tab. 

Cheers
Philippe

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from