eZ Community » Forums » Discussions » eZ Publish 4.3.0 released
expandshrink

Tuesday 30 March 2010 5:47:42 pm - 15 replies

» Read full blog post

Introduction

We are proud to announce the release of eZ Publish 4.3.0, after a development cycle of six months. This release contains many new features, performance enhancements and over 150 bug fixes in both the kernel as in its associated extensions compared to eZ Publish 4.2.0

Tuesday 30 March 2010 7:27:08 pm

Congratulations for this new release delivered on time, and thanks for all these new features !

One question about ezflow extension update from 4.2 : there are six packages to install, which may be long and a source of error when there are a lot of sites to update.

Would it be possible to know if updating the different extension folders will do the job as well, and if not to know which DB update is to be applied ?

Thanks,

Hakim

Tuesday 30 March 2010 8:46:32 pm

Hi folks,

I am very happy with the new release. After intensive testing the beta and rc releases, we decided to upgrade the first bigger site to 4.3: http://www.schicksal.com - a magazine for women with about 60k visits and 400k page impressions / month.

We use the new ezcomments extension there and the latest ezfind release.

The first impressions: The site generation is faster than before, the editors like the new admin interface very much!

So, good work!

Best wishes,
Georg.

Wednesday 31 March 2010 9:43:03 am

Hi.

If you upgrade from 4.2, you won't only need to run php bin/php/ezpgenerateautoloads.php --extension, but also php bin/php/ezpgenerateautoloads.php --kernel.

if not, you'd probably have some errors related to ezpI18n class.

Best.

edit: sorry. maybe it's not necessary. is just the way i've upgraded the thing happy.gif Emoticon.

Modified on Wednesday 31 March 2010 9:54:20 am by Carlos Revillo

Wednesday 31 March 2010 10:38:02 am

Hi,

Does anyone know where the description for a content class attribute appears when editing an object based on it?

Wednesday 31 March 2010 11:01:48 am

Eirik: http://ez.no/doc/ez_publish/user_...ks/editing_content#eztoc107908_0_1_1

Only supported by admin2 at the moment, but should be fairly easy to merge to webin(&flow) or custom designs, realted templates are content/edit.tpl and content/edit_attribute.tpl.

Modified on Wednesday 31 March 2010 11:02:35 am by André R

Wednesday 31 March 2010 12:31:14 pm

@André: Also, I guess it helps adding the description to the correct translation of the content class. happy.gif Emoticon

Wednesday 31 March 2010 12:32:32 pm

@Carlos: You might consider adding your comment to this page:

http://ez.no/doc/ez_publish/upgra...to_4_3/upgrading_from_4_2_x_to_4_3_x

Wednesday 31 March 2010 2:01:10 pm

I can't find doc about upgrading from 4.3 RC1 to 4.3 final ?

Do I need only to update files or there is DB changes ?

Wednesday 31 March 2010 2:09:50 pm

Hi,

Just repport an error .. You wrote :

  • templateInit() has been deprecated, so in the future calls to to get template instance should go via ezTemplate::factory()

and the correct sentence is eZTemplate::factory()

happy.gif Emoticon

Sunday 04 April 2010 3:34:10 pm

Just installed and tested a clean install of eZ Publish 4.3.0 (Light tar gz version) with eZ Webin with Norwegian language. Just browsing for a few minutes I discovered several issues that I believe should have been discovered before a stable release.

Norwegian translation

In the admin interface you have several places where strings are not translated. Example on the Dashboard page with "You are here", "All latest content" .. etc. This is the first you'll see when you log in to the admin interface.

Edit: sorry, both consistency check and notification settings earlier was an error in my local installation.

Forum

Testing the forum in the eZ Webin demo package, the next / previous links for Forum topics are not working after a clean install.

System information

The svn revision has been 666666 for the last alpha and beta releases. Not the most important one, but says something about the quality assurance for this release.

In my opinion this is still a beta release and I hope you'll release a new 4.3.1 that solves the issues above that I least expect should have been tested and working in a stable release.

Bjørn

Modified on Sunday 04 April 2010 4:08:40 pm by Bjørn Reiten

Tuesday 13 April 2010 6:23:34 pm

Okay what on earth is hapenning to the Override system??? I just installed the new version and I wanted to design a few templates by modifying the template overrides.

FIRST - Where is the design tab? Got it after a few searches using google.

SECOND - Where is the template list? Managed to see it under whatever.com/visual/templatelist

THIRD - I clicked on a template "node/view/full.tpl" and saw a list overrides.BUT Now I want to change any one of them. They have a thing called "No file matched" and then the edit button won't work! I tried to create an override. But it simply does NOT save it! WHY IS IT SO DIFFICULT with the new version??? What am I doing wrong? I am now at day 5 of trying to solve the template thing. I cannot find ANYTHING on the internet about it! Am I the ONLY one in the world with this problem??? Oh yeah I did reinstall it many many many times.

Please someone help me!

Thursday 15 April 2010 1:17:40 pm

@Matthieu: There are no db changes other then version number, you can always find sql files for that in update/database/<database>/<version>/unstable/*.sql.

@Bjørn: Just because your sorting bug which is a (non) issue with demo data since they happens to be created on the very same second is not fixed, that does not mean the rest of us consider this beta quality. As for svn version, it's know issue in the new build system so should be fixed in 4.4, but not something we considered as a blocker for the 4.3 release.

@Mihai007: It was decided to hide these features since they already where full of bugs and unmaintained, will probably be moved into an community extension for the next version as we don't use it ourself (we, like most other users edit templates and ini files using our favorite editor directly on the file system).

Modified on Thursday 15 April 2010 1:32:49 pm by André R

Friday 16 April 2010 5:32:17 pm

@Bjørn : you may want to have a look there : http://share.ez.no/forums/transla...the-4.3-norwegian-soon/(offset)/last

Cheers and thanks for the feedback !

Tuesday 20 April 2010 4:16:56 pm

Clarification regarding ezi18n() and templateInit():

These functions are used by all extensions, even our own, so we are not planning on removing these already in 4.4 but keep them around at least one more version. So you don't need to have version checks in your extension anytime soon, just keep on using the functions in your extensions if the extension is supposed to work in versions bellow 4.3 as well.

For our own extensions, we'll most likely do the change in next version, meaning all new versions of our extensions that are bundled with Fuji (4.4) will use the new api, thus require 4.3 and above.

Wednesday 11 August 2010 7:29:18 am

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from