eZ Community » Forums » Extensions » Call for testers: new Online Editor
expandshrink

Call for testers: new Online Editor

Call for testers: new Online Editor

Saturday 16 February 2008 7:55:45 pm - 303 replies

Hi all!

eZ Publish Online Editor 5.0 is now completed and included in eZ Publish 4.1.x and higher.

Extension:
http://projects.ez.no/ezoe

SVN:
http://svn.projects.ez.no/ezoe/

Issue tracker:
http://issues.ez.no/IssueList.php?ProjectId=4&ClearOk=1
* tag with the version you use, for instance 5.0.1
* mention svn version if you use svn version
* Remember to specify browser/version/os/javascript error
* Screen shoots if it applies

* Updated 6th of May 2009 with new location of extension (project.ez..no/ezoe) and state of extension.

Modified on Tuesday 11 January 2011 10:00:47 am by Nicolas Pastorino

Friday 29 August 2008 7:50:15 pm

Hi,

didn't override anything, just FF configuration to open new windows in a new tab (good), the part I don't like is TinyMCE resizing the window.

blunk.gif Emoticon

X+

Saturday 30 August 2008 8:54:44 pm

It's part of TinyMCE, and there are no settings to turn it of.
So the only option currently is to comment out the t.resizeToInnerSize(); line in tiny_mce_popup.js ( _onDOMLoaded() ).

Tuesday 02 September 2008 3:17:20 pm

Hi,

I am having some problems with line breaks.

How is it possible for a user to add a line break (<br />blunk.gif Emoticon using the TinyMCE UI ? (I tried different key sequence : Upper + CR , Ctrl + CR ...) but none of them is working...

Thank you for your help,
Hakim

Tuesday 02 September 2008 6:05:47 pm

Hi all,

Just downloaded the new on-line editor today to see what it is happening in this new version.

Few things:

1. Is there any facility to write alternative text while uploading the image or make alternative text as a mandatory option for the images.

2. How to make first row of the table as the table header.

3. How to go into table properties, Lets suppose need to change the width of the table after creating one with 100% width.

I have not seen anything related to the two points mentioned above, but I might be missing something in quick assessment.

Looking forward to hear from you guys.

Smith

Modified on Tuesday 02 September 2008 6:11:45 pm by John Smith

Tuesday 02 September 2008 6:49:24 pm

@hakim:
line breaks are done with ctrl + break (enter / cr)
But as mentioned earlier in this post: empty lines with linebreaks are removed by the ezxml input handler, and the only workaround currently is to add a empty space on each line or use empty paragraphs to make space between text sections.

@john:
1) supported in trunk
2) create a table, then open the properties on on of thecells on first row and change the type and select apply to row before you click ok.

Wednesday 03 September 2008 10:01:19 am

BTW: Google Chrome is out, and it works with OE 5.0 with no modifications since it is using the same Webkit engine as Safari. The Safari/Firefox version checking in OE 5.0 is actually looking for Webkit 522.0 / Gecko 1.8 or higher, so all newer webkit and gecko based browsers will work.

Safari 3.1.2 : Webkit 525.19
Google Chrome/0.2.149.27 (Beta 1) : Webkit 525.13

Note: Google Chrome has a different javascript engine then Safari, so we need to test it a bit when a stable version comes out before we add it to list of officially supported browsers.

For those that want to test this blazing fast browser, with brilliant tab handling, here's the link:
http://www.google.com/chrome

Wednesday 03 September 2008 10:29:49 am

Hi Andre,

I downloaded the Google Chrome the minute it was available last night... Tested few sites which are using 4.0.x with the latest on-line editor 4.x, but no luck it does not work, then I tried the latest on-line editor 5.0 which seems working...

In your second last post you replied that my points (alt text mandatory and table properties) are supported in trunk...

Is it possible to download the latest version from the trunk, if yes can I have the URL from where I can download the full code for the On-line Editor 5.x

A while ago I posted a post regarding the best on-line editor - "Xstandard", but somebody from the ezcrew were asking about their licenses.

Just want to update regarding their partnership for Open Source CMS.

http://www.xstandard.com/en/programs/xstandard-lite-for-partner-cms/

I do not whether this makes sense or not, just updating you guys.

Cheers,

Smith

Wednesday 03 September 2008 10:49:53 am

I downloaded the Google Chrome the minute it was available last night... Tested few sites which are using 4.0.x with the latest on-line editor 4.x, but no luck it does not work, then I tried the latest on-line editor 5.0 which seems working... 

This thread is about OE 5.x so why did you expect anything different?

Is it possible to download the latest version from the trunk, if yes can I have the URL from where I can download the full code for the On-line Editor 5.x

More info is in the first post in this thread and on the contribution page.

A while ago I posted a post regarding the best on-line editor - "Xstandard", but somebody from the ezcrew were asking about their licenses.

Why do you think we're interested in this at this point?
Should we throw away half a year worth of work + testing and start over?
Should we throw out one of the better open source editors and replace it with a property one?

Modified on Wednesday 03 September 2008 10:55:34 am by André R

Monday 08 September 2008 10:43:29 am

Hi Andre,

I have the following problem whenever I tried to set manually a url to an hyperlink:

- I edit the page: http://my.domain.name/home
- I add an hyperlink to a piece of text
- I choose a http type of hyperlink
- I paste : http://my.domain.name/<b>co...PNOE_Newsletter-6-March2008v.1.0.pdf

and ezoe systematically replace the URL I pasted with a relative url to my site (which is effectively on my.domain.name ) which is wrong:

../../<b>download</b>/5049/70136/file/EPNOE_Newsletter-6-March2008v.1.0.pdf

... and since it is automatically replaced by ezoe, I have no way to put the URL I want...

Note that I am using a PathPrefix in my [SiteAccessSettings].

Thank you for your help,
Hakim

Monday 08 September 2008 1:29:34 pm

@Hakim :

Thanks for the report, fixed it in svn and also uploaded new version (5.0.0rc5), it was a TinyMCE feature.
In the future, use the issue tracker, easier to track bug progress there.

Modified on Monday 08 September 2008 1:29:49 pm by André R

Thursday 11 September 2008 10:10:26 pm

Just a note to the ones already using OE 5.x actively:

There will soon be some small BC breaks in svn and the next rc, I didn't intend to do it at this stage so I apologizes for calling it RC a bit to early.

The changes are:
* OE specific settings blocks in content.ini will be moved to ezoe.ini to not give the impression that it's (including the validation) content related when it's actually pure OE gui related. Example block: [CustomAttribute_table_summary]
* The javascript / css cache will be placed in a common folder with a name like 'public' or 'share' so that the changes we do in rewrite rules now (ezp 4.1 for OE 5.0) can be reused later by similar cache types.

If there are any other inputs on stuff that should be considered cleaned up before stable, now is the time to mention it!

Tuesday 16 September 2008 3:02:19 pm

Hello,

I've been testing the 5.0rc5 version and I have a problem (i read the beginning of the thread and couldn't see anything related to this) : when I click on the element in the status bar, I have a popup (cool) with an error (not cool) : <i>Invalid parameter: TagName = [object htmlparagraphelement]</i>, it's the same with other tags (paragraph..). So i can not use my AvailableClasses per tags defined in content.ini.append.php

I checked in tags.php and editor_template.js it seems there's a test on the TagName value which is for instance <i>[object htmlparagraphelement]</i> instead of <i>paragraph</i> and so on for span and others...

Has this already been reported or corrected or am I missing some settings?

Thx

Gwenal

Tuesday 16 September 2008 3:17:21 pm

It was fixed right after rc5 was out:
http://svn.ez.no/svn/extensions/eztinymce/trunk/ezoe/changelog.txt
http://issues.ez.no/IssueView.php?Id=13486&activeItem=7

I'll upload rc6 later today to avoid problems for those that do not use svn.

Modified on Tuesday 16 September 2008 3:18:02 pm by André R

Tuesday 16 September 2008 3:55:59 pm

Thanks It's ok now!

Wednesday 24 September 2008 5:35:08 am

Just wondering if it's possible to create nested bulleted lists in the editor, without disabling it or pasting from elsewhere?

Wednesday 24 September 2008 12:04:51 pm

Yes, thats what the indent / outdent buttons are for.

Friday 03 October 2008 11:48:27 am

Hi,

I love the new OE but there is just one issue so far.

This is just an observation, but when you need to edit an image or link etc, is the prescribed method to select the item and then click the function on the menu bar.

For example. To change an image you need to click the image and then click the image link.

Is this a feature or a bug? What happened to context sensitive menus on the images, links, tables etc.

Tony

Friday 03 October 2008 12:08:40 pm

> For example. To change an image you need to click the image and then click the image link.

I guess you talk about the image icon, you can also click on the 'embed' link in the bottom path status bar, or any of the other tags in your current path for that matter.

> Is this a feature or a bug? What happened to context sensitive menus on the images, links, tables etc.

It's a feature, to be able to have access to the native right click menu of the browser, for spell checking first and foremost.

Friday 03 October 2008 12:37:28 pm

Hi Andre,

Thanks for this, you know, I had totally missed that bar, I thought it was information only and not active.

As a suggestion, could the bottom bar background change to orange like the bar at the top when the user selects an active area. This would then let the use know that they can use it to change the current selection. This would enable it to be more intuitive, at least to me.

Thoughts?

Friday 03 October 2008 12:51:25 pm

Great feedback.
Have been looking for ways to make it more intuitive, no other editor (even stock tinyMCE) does it like this so your not the first to ignore it.

I guess the current (rightmost) tag should have a orange background and not the whole bar?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from