eZ Community » Forums » Extensions » Call for testers: new Online Editor
expandshrink

Call for testers: new Online Editor

Call for testers: new Online Editor

Saturday 16 February 2008 7:55:45 pm - 303 replies

Hi all!

eZ Publish Online Editor 5.0 is now completed and included in eZ Publish 4.1.x and higher.

Extension:
http://projects.ez.no/ezoe

SVN:
http://svn.projects.ez.no/ezoe/

Issue tracker:
http://issues.ez.no/IssueList.php?ProjectId=4&ClearOk=1
* tag with the version you use, for instance 5.0.1
* mention svn version if you use svn version
* Remember to specify browser/version/os/javascript error
* Screen shoots if it applies

* Updated 6th of May 2009 with new location of extension (project.ez..no/ezoe) and state of extension.

Modified on Tuesday 11 January 2011 10:00:47 am by Nicolas Pastorino

Wednesday 10 December 2008 6:52:16 pm

Hi Jérôme,

Thanks for your help !

It's strange but my <img> isn't enclosed by any other tag, and doesn't has any CSS class or id...

I use this to render the xml content :

{attribute_view_gui attribute=$node.object.data_map.newscontent}

I have already modified my apache rewrite rules like as asked in the INSTALL doc...

Thursday 11 December 2008 9:20:38 am

Mmm... Is your image flagged as <i>inline</i> ? If so, I think that the standard template for inline objects (embed-inline.tpl), such as images, doesn't enclose your object with a <div> tag, while the embed.tpl does.
Try to use the non-inline version then happy.gif Emoticon.

Thursday 11 December 2008 9:46:18 am

Yes, I was using the inline flag, and I had not called all the good css rules like

...
div.object-left div.content-view-embed div.class-image div.attribute-image
{
    margin: 0;
    float: none;
}
...

Who are in ezwebin/stylesheets/core.css and content.css

All is OK now, thx !!!

Monday 05 January 2009 11:20:22 pm

Great job on the editor. Everything seems to be working smooth now. Except when you use IE 7. I have tried this on two different sites now with the same version of the editor rc9.
1) Open an article for edit
2) Save draft a couple times.. you should see space between text blocks increase. For every time you save the editor put in another

<p></p>

between text blocks.

Usualy you should not notice this space, but in our code i have reset the fonts in the css with yui, and have to set p tags with margin-bottom: 1em to give space between text.

Tuesday 06 January 2009 9:43:18 am

Yes it should have been fixed in svn a couple of weeks ago:
http://svn.ez.no/svn/extensions/eztinymce/trunk/ezoe/changelog.txt
http://issues.ez.no/IssueView.php?Id=14110&activeItem=2

I only thought rc10 (included in eZ Publish 4.1alpha1) was affected though, thats why I haven't rolled out a new rc yet.

Tuesday 06 January 2009 10:53:31 am

Updated to the latest in svn, works great now. Thanks!
Starting to smell a release now! Great job! This has been the most important update for eZ in years!

Wednesday 07 January 2009 12:44:56 pm

Hi,

I have a problem with the "none" alignment. When I put

{$object_parameters|attribute(show)

in templates\content\datatype\view\ezxmltags\embed.tpl, I confirm that alignement is empty. But, when I save my object, the alignment is at "right"... Is there a configuration for use alignment "none"?

Wednesday 07 January 2009 1:09:28 pm

The second time you save it? With editor disabled or enabled?
This is probably caused by the xml handler in ezp, as align=right is defined as default in the xmlscheme.

Thursday 08 January 2009 10:05:20 am

Hi André,

With editor enabled.
There isn't any other solution that hacking kernel/classes/datatypes/ezxmltext/ezxmlschema.php ?

Thursday 08 January 2009 3:26:18 pm

Well the editor could set align="none" and then you would only have to work with that in your templates.

EDIT: But thats not a very clean approach, so best way is to solve it in eZ Publish 4.1* or remove it from OE 5.
A script will be needed to set align to right if not set on embed / embed-inline tags since some xml handlers are set to omit attributes that have default value.

Modified on Thursday 08 January 2009 3:51:06 pm by André R

Wednesday 14 January 2009 5:13:48 pm

I've found a couple of problems in the latest release:

1) If you have a table with an embedded object in each cell I try to add a row in the table in the middle. In Firefox I click on a cell/embeded object, click "table row" in the path and "table buttons" in OE lit up so I can add a new row. If I try this in IE the "table buttons" aren't lit up (still only the paperclip) so I cant add a row.

2) Drag and drop of embedded objects looks like they works (in IE) but it doesn't. Not sure if it's supposed to work or not, but if it's not supposed to work then the GUI shouldn't show it.

Monday 26 January 2009 2:27:09 pm

Hi,

maybe this is the wrong place to ask...
But since i had this problem also with ezoe involved and you are the people professional in content input, you maybe could have a look at my post in the forum: http://ez.no/developer/forum/setu...ign/text_input_gets_damaged_stripped

Thanks for your help!
Ciao, Tobias

Monday 26 January 2009 2:28:06 pm

Hi,

In this translation : fre-fr, ita-it and pol-po, the <defaultcodec></defaultcodec> cause an error : "Unknown element name: defaultcodec".

Modified on Monday 26 January 2009 2:28:37 pm by Guillaume Kulakowski

Tuesday 27 January 2009 4:27:56 pm

Tables are dropped when pasting from MS Word on Macintosh. And I guess other formatting aswell. Bullettpoints works.

This new editor looks fine. I liked the search feature when looking for objects.

My version of word is 12.1.4
Editor is Versjon: 5.0.0rc12
tiny is Versjon: 3.2.1.1 (2008-11-27)

Wednesday 28 January 2009 12:54:48 am

Guillaume: fixed, but in the fr ts file language is wrong 'TS version="1.1" language="en_US"', do you know what it is supposed to be? fr_FR?
As for alignment, all the alignment stuff is implemented now in Alpha2 including upgrade script, so you can test it or read more here:
http://issues.ez.no/IssueView.php?Id=13860&activeItem=9

Jo Henrik: 1+2 could you create issues in the oe issue tracker? As for #2, its neither intentional nor disallowed, I'll probably need to disable it somehow using onmouseup="return false;" or some other trick. And those that need to be able to move them around would need to enable CompatibilityMode.

Erland: Could you crate a issue for this in the oe issue tracker so we can track this (as in not forget), please also try to state what browser you are using + version, and also if it is reproducible on windows.

Wednesday 28 January 2009 4:25:25 pm

> Guillaume: fixed, but in the fr ts file language is wrong
> 'TS version="1.1" language="en_US"', do you know what it is supposed to be? fr_FR?
Yes

Wednesday 28 January 2009 9:30:33 pm

I wonder if anyone can replicate my "insert File" behaviour problem from within ezoe? I'm using one of the latest SVN releases (revision 3551) and when I insert a link to a file using the 'insert/edit file' button on the toolbar, strange things happen: (using FF3.0.4 on Win2k and Linux FC9)

* Open an article for editing.
* Select the "Insert/Edit File" icon on the editor toolbar.
* Upload a PDF from your filesystem, name it etc, then press "Upload Local File".
* The popup refreshes itself with pre-filled input-fields of the uploaded file
* Select "embed-inline" from the "View" menu, leave other input defaults, then press "OK".
* Press "Save and Publish" and click the link to the uploaded file.

I get a "Module Not Found" error to the URL: /my-siteaccess/Media/Files/ez-publish-ezoe-my-uploaded-file.pdf

The same thing happens when linking directly to a pre-existing file using the 'insert/edit link' from the editor toolbar, but this has been logged in the issue-tracker (#14100)

[UPDATE]
Try this also (but is essentially the same thing) add a link to a File using the 'insert/edit file' button, then in th epopup window, switch the 'view' that is used - this (as far as I know) is the view of how the link is presented 'on-screen'.

But when you switch from 'embed' to 'embed-inline', where the Preview at the bottom of the popup changes - the way the link actually works, seems to change too. So where 'view' = 'embed' I am prompted to download the file - as I'd expect. But where 'view' = 'embed-inline' the link changes so when I select it in the preview and also in the saved article, I get 'Module Not Found'.
[/UPDATE]

Is this really a bug or could it be an issue elsewhere? I thought it might be to do with some ReWrite Rules in .htaccess so I reverted it back to the install version - still no joy.

Can someone else give this a go when they have a moment? I'd really appreciate it as I'm not sure whether it's something I've done or an actual Bug.

Many thanks for your time people happy.gif Emoticon

Modified on Thursday 29 January 2009 2:04:04 am by Russell Michell

Thursday 29 January 2009 12:55:12 pm

I get a "Module Not Found" error to the URL: /my-siteaccess/Media/Files/ez-publish-ezoe-my-uploaded-file.pdf

It's looks like it is your rewrite rules, as most file extension are normally only allowed from the var/ folder in .htaccess rules.
Why do you call your object '*.pdf' ?

Add pdf to the file extensions in the start of the rewrite rules to allow it ("(gif|jpe?g|png|css|js|html)"blunk.gif Emoticon

Thursday 29 January 2009 5:27:41 pm

Hi André

Just a small one.. Could the file upload size display display in human readable format ie File size limit 2mb, rather than File size limit 2000000000000000

This would be great.. If this can then be implemented everywhere else in eZ too, if possible

Thanks

Tony

Monday 02 February 2009 2:16:33 am

Hi and thanks but:

It's looks like it is your rewrite rules, as most file extension are normally only allowed from the var/ folder in .htaccess rules.

Sure, but using View = 'embed' or 'full', it's OK (without further modifications to .htaccess) - I can download the PDF but using view = 'embed-inline' it breaks causing 'Module not found'.

Why do you call your object '*.pdf' ?
> I don't, th file I'm uploading is called 'my-file.pdf' on the filesystem. I upload this PDF and when I go to select it in the 'insert/edit file' popup, the URL in the preview section is 'http://my-host/my-siteaccess/content/download/1234/5678/file/my-file.pdf'.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from