This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » eZ Find » Ezfind fails to sort on...
expandshrink

Ezfind fails to sort on ezobjectrelationlist datatype attributes

Ezfind fails to sort on ezobjectrelationlist datatype attributes

Thursday 20 September 2012 4:38:32 pm - 1 reply

Hello,

I came upon this issue few days ago, when I tried to add sorting to ezfind fetch as documented into manual:

sort_by, hash( 'class_identifier/attribute_identifier', asc )

At first I thought it's something wrong with my code, then I tried to use attribute id instead of identifiers for class and attribute. Needless to say, result was the same.

Since problems have been known to exists with ezfind and ezobjectrelationlist datatype attributes for years (including the indexation), I decided to test the sort_by option with attribute of ezobjectrelation datatype. Without surprise it worked, so the conclusion was sort_by is useless when exercised upon ezobjectrelationlist datatype.

I did not find anything in issue tracker on this; seems no one has EVER tried to sort on multiple relation attributes so far, which puzzles me. Haven't ANYONE stumbled upon this?? It's not reported, it's not even mentioned anywhere. Any advise, patch, hint (except to change all my attributes to single relations)?

[eZFind 2.7 stable, eZPublish CP2011.10]

Modified on Monday 01 October 2012 2:14:43 pm by Denitsa M

Wednesday 05 June 2013 9:37:17 am

Hi Denitsa M,

unfortunately, sorting on multi-valued fields is not allowed by the solR engine.

regards!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from