This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » eZ Find » ezfind : try to index each items of...
expandshrink

ezfind : try to index each items of ezobjectrelationlist

ezfind : try to index each items of ezobjectrelationlist

Thursday 02 October 2014 9:09:13 am - 1 reply

Hi all,

I try to index all items of ezobjectrelationlist on solr index but i've a big problem : 

I use this datatype to make my facets.

I changed my ezfind.ini file with this parameters :

DatatypeMap[ezobjectrelation]=string
DatatypeMap[ezobjectrelationlist]=string
...
DatatypeMapFacet[ezobjectrelation]=string
DatatypeMapFacet[ezobjectrelationlist]=string

I tried default settings on classes/ ezfsolrdocumentfieldobjectrelation.php :

 public static $subattributesDefinition = array( self::DEFAULT_SUBATTRIBUTE => 'text' );
 
const DEFAULT_SUBATTRIBUTE = 'full_text_field';

I've just string like "my", "custom", "content", "content2" on my solR index.

I try custom settings on this same file :

 public static $subattributesDefinition = array( self::DEFAULT_SUBATTRIBUTE => 'string' );
 
const DEFAULT_SUBATTRIBUTE = 'name';

I've all my  values concatenate like "my custom content my custom content2".

In both case, I didn't change my schema.xml file.

What I want ?

Simply index each values on my solr index like this :"my custom content", "my custom content2".

Do you have any idea to solve my issue ?

Thanks for your reply,

Monday 06 October 2014 12:17:39 pm

Hi all,
After many tests, I solved my issue with this reply in another topic : http://share.ez.no/forums/developer/ezfind-challenges#comment76898
In fact, I took this code and I adapts it on my particular case.

I create a file named multivalueezfindindexobjectrelations.php in my extension path classes/indexplugins/ with the same values as described Patrick Kaiser.

I update my ezfind.ini.append.php file with this value :

 [IndexPlugins]
General[]
General[]=multiValueEzfIndexObjectRelations

And finally, I regenerate autoloads, clear cache and index my content : 

 php bin/php/ezpgenerateautoloads.php -e -p
 php bin/php/ezcache.php --clear-all
 php extension/ezfind/bin/php/updatesearchindexsolr.php -s [ADMIN_SITEACCESS] --php-exec=php --clean

(I'm in dev environment, take care if you clear all cache on production environment - Change [ADMIN_SITEACCESS] by your value).

And it works !

Regards

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from