This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Extensions » eZ Find » How to search the exact word by Ezfind ?
expandshrink

How to search the exact word by Ezfind ?

How to search the exact word by Ezfind ?

Thursday 20 January 2011 4:36:03 am - 6 replies

Hello, I'm using the ezfind extension. But I can't search the exact word. For example, when I search the text "consid", the article with word "considered" will be searched. How can I do some settings so that Ezfind can search the exact word?

Thursday 20 January 2011 1:53:19 pm

What is your default search handler ([SearchHandler] / DefaultSearchHandler in ezfind.ini)? I have heuristic and if I search "Strasb" insted "Strasbourg", I have no response.

Modified on Thursday 20 January 2011 1:54:02 pm by Guillaume Kulakowski

Friday 21 January 2011 3:49:54 am

My DefaultSearchHandler is heuristic too. So strange.

Friday 21 January 2011 3:54:02 am

I have set it to heuristic.

Monday 07 February 2011 10:47:46 pm

What you see is the stemming in action which is enabled by default.

If you really want to turn this off, you need to edit the solr schema.xml file and remove the stemming step for the "text" type field.

Then re-index (as with any schema change) and you will only have matches of the exact term (still case insensitive and with accesnts removed)

Paul

Tuesday 08 February 2011 10:47:30 am

Also, if you just want to prevent some words to be stemmed, and not all of them (common case: the company name and its products), you can modify the protwords.txt configuration file. It's a list of words to which stemming is not applied.

Saturday 26 September 2015 12:14:33 am

* Credit goes to Miro K. @ Beaconfire RedEngine *

This is a different technique for running an exact search. It does not require changing Solr schema or disabling the tokenizer.

The premise is to NOT query any string, but use the filter instead.

 

Goal: Search for exact statement: "99 red balloons"

Config: 'allow blank searches' to be enabled

Set the 'search' value to [""] (blank)

Set the 'filter' value to [ ezf_sp_words:'99 red balloons' ]

The single quotes work for ez 4.6

Be careful of 'or' conditions in your filter.

Modified on Saturday 26 September 2015 1:04:15 am by David Sayre

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from