This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Extensions » eZ Find » no search results
expandshrink

no search results

no search results

Tuesday 15 April 2014 11:44:25 pm - 8 replies

We had this working and then I thought the index was missing some items that didn't come up within search.

So I ran 

php extension/ezfind/bin/php/updatesearchindexsolr.php -s site_admin --php-exec=php --conc=1

and it appeared to index but my missing items did nots how up, so I ran

php extension/ezfind/bin/php/updatesearchindexsolr.php -s site_admin --clean --php-exec=php --conc=1

and again it appeared to index but now there are zero search results. I have tried to reindex without the --clean option and it tells me 100% done with 21566 items indexed but there are still no search results. 

Do you have any ideas?

Wednesday 16 April 2014 12:06:55 am

Items do come up in search immediately after editing and publishing.

 

I found this forum post with the same problem:

http://share.ez.no/forums/extensi...x-existing-or-new-content-in-solrand

 

Their solution was:

"It turned out that we had configured eZFind incorrectly and pointed it to the wrong database schema. Problem solved." Any idea what this means?

Modified on Wednesday 16 April 2014 12:17:20 am by Thaler Thaler

Wednesday 16 April 2014 12:30:00 pm

You should check the solr daemon output when reindexing. On schema problems solr throws mostly java exceptions. Just run solr in a shell and look at the output.

To verify if you have physical data in your index go to port :8983/solr/admin and see if you can query manually or look at the statistics. If yes the most common problem is the language filter defined in the SiteLanguageList array in siteaccess.

Wednesday 16 April 2014 1:32:00 pm

Thank you for your help. I checked statistics in :8983/solr/eng-US/admin and there are two documents (numDocs : 2 ) which are the ones we edited and published.

 

In settings/override/site.ini.append.php I added to [RegionalSettings]

SiteLanguageList[]=eng-US

Did I set this SiteLanguageList correctly?

Re-ran the update script, which came back with 100% 34692 items, and search comes back with zero results.

 

When you say run solr in a shell you mean start solr manually? This is what we run:

java -Djetty.port=8983 -Dsolr.solr.home=solr.multicore -jar start.jar

with no errors.

 

When I run the reindex script:

php extension/ezfind/bin/php/updatesearchindexsolr.php -s site_admin --php-exec=php --conc=1 --allow-root-user

I get:

Creating a new thread: 34680.................................................. 99.88%...100.00%

Running scripts as root may be dangerous.If you think you know what you are doing, you can run this script with the root account by appending the parameter --allow-root-user.
Did not index content correctly:array ()

Modified on Wednesday 16 April 2014 1:34:09 pm by Thaler Thaler

Wednesday 16 April 2014 2:03:13 pm

I added this section to settings/override/ezfind.ini.append.php

[RegionalSettings]

SiteLanguageList[]

SiteLanguageList[]=eng-US

Multicore=enabled

DefaultCore=eng-US

LanguagesCoresMap[]

LanguagesCoresMap[eng-US]=eng-US

 

I restarted solr and get back console output, one line reads:

INFO: JNDI not configured for solr (NoInitialContextEx)

Wednesday 16 April 2014 3:09:38 pm

You must see a addDoc command for each object indexed by the script without exceptions in the solr stdout?

Try running index script not as root, there is a bug not passing the -r parameter to forked subprocesses.

Wednesday 16 April 2014 3:39:58 pm

Thank you!

 

I added apache to sudoers to run updatesearchindexsolr:

# visudo

apache ALL=(root) NOPASSWD: /usr/bin/php extension/ezfind/bin/php/updatesearchindexsolr.php -s site_admin --php-exec=php --conc=1

 

Then reindexed as apache user:

# cd /var/www/html/oursite

# sudo -u apache php extension/ezfind/bin/php/updatesearchindexsolr.php -s site_admin --php-exec=php --conc=1

And it reindexed the site. Thanks again for your help. happy.gif Emoticon

 

Starting object re-indexingUsing fork.Using 1 concurent process(es)Number of objects to index: 2453
Creating a new thread: 36502...................................................................... 2.85%...................................................................... 5.71%............................................................Creating a new thread: 36522.......... 8.56%...................................................................... 11.41%...................................................................... 14.27%..................................................Creating a new thread: 36529.................... 17.12%...................................................................... 19.98%...................................................................... 22.83%........................................Creating a new thread: 36534.............................. 25.68%...................................................................... 28.54%...................................................................... 31.39%..............................Creating a new thread: 36540........................................ 34.24%...................................................................... 37.10%...................................................................... 39.95%....................Creating a new thread: 36546.................................................. 42.80%...................................................................... 45.66%...................................................................... 48.51%..........Creating a new thread: 36591............................................................ 51.37%...................................................................... 54.22%...................................................................... 57.07%
Creating a new thread: 36596...................................................................... 59.93%...................................................................... 62.78%............................................................Creating a new thread: 36604.......... 65.63%...................................................................... 68.49%...................................................................... 71.34%..................................................Creating a new thread: 36639.................... 74.19%...................................................................... 77.05%...................................................................... 79.90%........................................Creating a new thread: 36691.............................. 82.76%...................................................................... 85.61%...................................................................... 88.46%..............................Creating a new thread: 36696........................................ 91.32%...................................................................... 94.17%...................................................................... 97.02%....................Creating a new thread: 36702.................................................. 99.88%...                                                                    100.00%
Creating a new thread: 36707
Creating a new thread: 36712
Creating a new thread: 36717Process finished: 36717Optimizing. Please wait ...Indexing took 140.6051940918 secs ( average: 17.446012687117 objects/sec )Finished updating the search index.

Wednesday 16 April 2014 4:04:58 pm

And it reindexed the site. Thanks again for your help.

It's fine now?

 

This looks fine, you realize that it's ignoring "--conc=1"? Still makes more threads..

BUT much more important is the solr daemon stdout? Any "addDocs" and "commits" there?

Modified on Wednesday 16 April 2014 4:06:28 pm by Artur Wawrzynkiewicz

Tuesday 22 April 2014 2:46:02 pm

Yes, it's fine now, search is working. No, I did not realize "--conc-1" does not do anything. I will remove it, thank you for the tip. 

 

I have not tried the daemon. When starting manually there are no "addDocs" or "commits". It just says the above output in a previous post. I plan on trying to set it up as a daemon.

The number of docs in the solr admin statistics show numDocs : 2460 instead of 2.

Thank you for the follow-up. happy.gif Emoticon

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from