This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Extensions » eZ Find » solr keeps stopping
expandshrink

solr keeps stopping

solr keeps stopping

Wednesday 09 April 2014 5:30:49 pm - 4 replies

eZFind and solr work when we start it and after a day or two, sometimes less, solr stops. We do a ps -ef | grep solr and nothing is running.

So what we do is:

cd /var/www/html/oursite/extension/ezfind/java/

java -jar -Djetty.port=8983 -Dsolr.solr.home=solr.multicore -jar start.jar > /dev/null 2>&1 &

 

Which works and then we have to repeat this every day. We tried to run it as a daemon and ran into problems. Would it be worth it to try running it as a daemon or do you know if there is something to check? I looked in the site logs and saw nothing about search.

Wednesday 09 April 2014 11:56:42 pm

Give it memory. A lot. It probably crashes due ot not enough memory. I am sure default settings are not enough. E.g. call it like this (or even more): 

java -Xms512M -Xmx1024M -jar ....

Friday 11 April 2014 5:01:52 pm

Ivo is probably right.  You can confirm that it is a memory issue by checking the operating system's log, usually located at /var/log/messages

Tuesday 15 April 2014 11:14:26 pm

nohup java -jar .... 

seemed to work for a couple of days.

 

I'll try the memory settings. Thanks for both of your help.

Friday 25 April 2014 3:48:16 pm

Yes, it was out of memory. In /var/log/messages:

Apr 24 13:45:48 ourserver kernel: Out of memory: Kill process 54458 (java) score 65 or sacrifice child

Apr 24 13:45:48 ourserver kernel: Killed process 54458, UID 0, (java) total-vm:1230852kB, anon-rss:150904kB, file-rss:44kB

 

When I tried to run java -Xms512M -Xmx512M -jar .... Java would not start and hs_err_pid19378.log got generated in /var/www/html/oursite/extension/ezfind/java:

# There is insufficient memory for the Java Runtime Environment to continue.

# Native memory allocation (malloc) failed to allocate 357957632 bytes for committing reserved memory.

# Possible reasons:

# The system is out of physical RAM or swap space

So I allocated more memory to the virtual machine and restarted java with our original command. Thank you for all of your great help.

Modified on Friday 25 April 2014 3:51:08 pm by Thaler Thaler

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from