eZ Community » Forums » Extensions » eZ Find » Solr Startup does nothing, process...
expandshrink

Solr Startup does nothing, process doesn't exist

Solr Startup does nothing, process doesn't exist

Monday 17 June 2013 10:48:56 pm - 3 replies

  • RHEL 5.9 "Tikanga", yum update recently ran. Fresh server otherwise.
  • eZPublish 2011.4
  • eZFind 2.3 (with some updates such as node priority, storing multiple fields)
  • PHP 5.3.3
  • Java Open JDK 1.6 and Open JDK-devel :
    • java version "1.6.0_24"
    • OpenJDK Runtime Environment (IcedTea6 1.11.11) (rhel-1.40.1.11.11.el5_9-x86_64)
    • OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
  • [root@localhost changelogs]# yum list installed | grep java
    java-1.6.0-openjdk.x86_64               1:1.6.0.0-1.40.1.11.11.el5_9   installed
    java-1.6.0-openjdk-devel.x86_64         1:1.6.0.0-1.40.1.11.11.el5_9   installed
    tzdata-java.x86_64                      2013c-1.el5                    installed

 

After issuing: java -jar start.jar I get nothing. My terminal doesn't get used. It's as if Java just quits.

Using java -verbose -jar start.jar I get a lot of classes loaded, no exceptions, no errors and then I just get a new line and prompt. I can paste in the verbose output that happens. But here's a truncated version:

 

[root@localhost java]# java -verbose -jar start.jar
[Opened /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/rt.jar]
[Loaded java.lang.Object from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/rt.jar]

.....

[Loaded java.util.HashMap$KeySet from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/rt.jar]
[Loaded java.util.LinkedHashMap$LinkedHashIterator from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/rt.jar]
[Loaded java.util.LinkedHashMap$KeyIterator from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/rt.jar]
[root@localhost java]#

 

Running ps aux | grep java | grep -v grep shows nothing. ps -af, nothing.

 

Any ideas? Any help would be greatly appreciated!

Modified on Monday 17 June 2013 10:51:21 pm by Brandon Chambers

Tuesday 18 June 2013 12:36:35 am

I inadvertently marked this as 'solved' while I was trying to click the breadcrumb above the forum link.

Admin: please mark as unsolved.

Tuesday 18 June 2013 9:24:25 pm

Yea so I tried dropping in a new ezfind extension. Worked fine.

Problem was ezfind/java/etc/jetty.xml was missing from the extension.

confused.gif Emoticon

 

Special thanks to: Graham Brookins / kracker (IRC) & Peter Keung

Modified on Tuesday 18 June 2013 9:31:06 pm by Brandon Chambers

Monday 24 June 2013 3:51:11 pm

Hello Brandon,

Your welcome. Happy to help!

Glad to hear you solved the problem.

Thank you for sharing the cause/solution.

Cheers,
//kracker

Theme: Juicy J and Kreayshawn - U Trippy Mane
Mirror: http://www.youtube.com/watch?v=D4BTpdue7fc

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from